aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2022-02-01 21:35:06 +0200
committerStijn Tintel <stijn@linux-ipv6.be>2022-02-01 21:35:15 +0200
commitcd6a6e3030ff9b758469cc159c219bc7a49df5e8 (patch)
tree2904885f0adf186677182ad246979d5e2a9f9e63 /target/linux/ramips/image
parentda8b720b0ecbb6d58f28a31b082b0c53be149a5a (diff)
downloadupstream-cd6a6e3030ff9b758469cc159c219bc7a49df5e8.tar.gz
upstream-cd6a6e3030ff9b758469cc159c219bc7a49df5e8.tar.bz2
upstream-cd6a6e3030ff9b758469cc159c219bc7a49df5e8.zip
Revert "ramips: add support for ipTIME AX2004M"
Commit f4a79148f8cb ("ramips: add support for ipTIME AX2004M") seems to leak KERNEL_LOADADDR 0x82000000 to other devices, causing the to no longer boot. The leak is visible in u-boot: Using 'config-1' configuration Trying 'kernel-1' kernel subimage Description: MIPS OpenWrt Linux-5.10.92 Type: Kernel Image Compression: lzma compressed Data Start: 0x840000e4 Data Size: 10750165 Bytes = 10.3 MiB Architecture: MIPS OS: Linux Load Address: 0x82000000 Entry Point: 0x82000000 Normally, it should look like this: Using 'config-1' configuration Trying 'kernel-1' kernel subimage Description: MIPS OpenWrt Linux-5.10.92 Type: Kernel Image Compression: lzma compressed Data Start: 0xbfca00e4 Data Size: 2652547 Bytes = 2.5 MiB Architecture: MIPS OS: Linux Load Address: 0x80001000 Entry Point: 0x80001000 Revert the commit to avoid more people soft-bricking their devices. This reverts commit f4a79148f8cbb7dfbcddfb0c1128caec45a01596. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk20
1 files changed, 0 insertions, 20 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index b125df48d9..a461c57f15 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -817,26 +817,6 @@ define Device/iptime_a8004t
endef
TARGET_DEVICES += iptime_a8004t
-define Device/iptime_ax2004m
- $(Device/dsa-migration)
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- KERNEL_SIZE := 4096k
- IMAGE_SIZE := 121344k
- UBINIZE_OPTS := -E 5
- KERNEL_LOADADDR := 0x82000000
- KERNEL := kernel-bin | relocate-kernel 0x80001000 | lzma | \
- fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
- IMAGES += recovery.bin
- IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
- IMAGE/recovery.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | \
- check-size | iptime-crc32 ax2004m
- DEVICE_VENDOR := ipTIME
- DEVICE_MODEL := AX2004M
- DEVICE_PACKAGES := kmod-mt7915e kmod-usb3
-endef
-TARGET_DEVICES += iptime_ax2004m
-
define Device/iptime_t5004
$(Device/dsa-migration)
BLOCKSIZE := 128k