aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2022-02-18 00:23:45 +0100
committerSungbo Eo <mans0n@gorani.run>2022-03-16 22:31:14 +0900
commitbe89c9eec4c28123b61ed020ad5b8b02905e73af (patch)
tree151238921999186e45c5f8e8cb6efbf7aa381881 /target/linux/ramips/image
parent832b90216f5d9f5c825d7c89609fde9508d48d57 (diff)
downloadupstream-be89c9eec4c28123b61ed020ad5b8b02905e73af.tar.gz
upstream-be89c9eec4c28123b61ed020ad5b8b02905e73af.tar.bz2
upstream-be89c9eec4c28123b61ed020ad5b8b02905e73af.zip
ramips: mt7620: Add support for D-Link DWR-961 A1
The DWR-961 A1 Wireless Router is based on the MT7620A SoC. It's a merge of two Amit boards: DWR-960 with ethernet part of Lava LR-25G001. ROMID it's taken from Telenor branded version and it works with tested device. Images from D-Link site for this router are from DWR-953 and it have ROMID DLK6E2424001. I don't know if it's mistake on web-site or if it's will require different image. Specification: - MediaTek MT7620A (580 Mhz) - 128 MB of RAM - 16 MB of FLASH - 1x 802.11bgn radio - 1x 802.11ac radio (MT7612 mpcie card) - 5x 10/100/1000 Mbps Ethernet: 4xLAN and 1xWAN (QCA8337) - 2x internal, non-detachable antennas (Wifi 2.4G) - 3x external, detachable antennas (2x LTE, 1x Wifi 5G) - 1x LTE modem cat 6 - UART (J5) header on PCB (57600 8n1) - 13x LED, 2x button - JBOOT bootloader Installation: Apply factory image via http web-gui or JBOOT recovery page How to revert to OEM firmware: - push the reset button and turn on the power. Wait until LED start blinking (~10sec.) - upload original factory image via JBOOT http (IP: 192.168.123.254) Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7620.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 5efb4e5e17..49d25b947f 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -314,6 +314,21 @@ define Device/dlink_dwr-960
endef
TARGET_DEVICES += dlink_dwr-960
+define Device/dlink_dwr-961-a1
+ $(Device/amit_jboot)
+ SOC := mt7620a
+ IMAGE_SIZE := 16256k
+ DEVICE_VENDOR := D-Link
+ DEVICE_MODEL := DWR-961
+ DEVICE_VARIANT := A1
+ DLINK_ROM_ID := DLK6E3813001
+ DLINK_FAMILY_MEMBER := 0x6E38
+ DLINK_FIRMWARE_SIZE := 0xFE0000
+ DEVICE_PACKAGES += kmod-mt76x2 kmod-usb-net-qmi-wwan kmod-usb-serial-option \
+ uqmi
+endef
+TARGET_DEVICES += dlink_dwr-961-a1
+
define Device/domywifi_dm202
SOC := mt7620a
IMAGE_SIZE := 16064k