aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2022-02-24 23:17:45 +0900
committerSungbo Eo <mans0n@gorani.run>2022-03-09 15:38:36 +0900
commit94d4269ec720db66ec8b92df1821ef19330897b1 (patch)
tree5e4f33e58065bfc1c969a3278a1ad82d722f542b /target/linux/ramips/image
parent2876f7534fe84f047f02bdda2886a9aeedbb8e76 (diff)
downloadupstream-94d4269ec720db66ec8b92df1821ef19330897b1.tar.gz
upstream-94d4269ec720db66ec8b92df1821ef19330897b1.tar.bz2
upstream-94d4269ec720db66ec8b92df1821ef19330897b1.zip
ramips: fix DEVICE_VENDOR for unbranded devices
In commit ee66fe4ea9a6 ("ramips: convert DEVICE_TITLE to new variables"), DEVICE_VENDOR of some unbranded devices were set incorrectly: * WR512-3GN is not a dev board from Ralink. * "XDX-RN502J" is the whole model name and should be not split. This patch sets their DEVICE_VENDOR to "Unbranded", and changes their DTS model properties accordingly. Ref: d0bf15f23595 ("ramips: add support for A5-V11 board (resubmit)") Ref: 9085b05d9e71 ("ramips: rt305x: support for wr512-3gn-like routers") Ref: 0e486d2fd297 ("ramips: add support for unbranded XDX-RN502J board") Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/rt305x.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index d8ea1d5673..d0a0d6f85a 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -1071,7 +1071,7 @@ define Device/unbranded_a5-v11
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | \
poray-header -B A5-V11 -F 4M
- DEVICE_VENDOR :=
+ DEVICE_VENDOR := Unbranded
DEVICE_MODEL := A5-V11
DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2
SUPPORTED_DEVICES += a5-v11
@@ -1082,7 +1082,7 @@ TARGET_DEVICES += unbranded_a5-v11
define Device/unbranded_wr512-3gn-4m
SOC := rt3052
IMAGE_SIZE := 3776k
- DEVICE_VENDOR := Ralink
+ DEVICE_VENDOR := Unbranded
DEVICE_MODEL := WR512-3GN
DEVICE_VARIANT := 4M
SUPPORTED_DEVICES += wr512-3gn-4M
@@ -1093,7 +1093,7 @@ TARGET_DEVICES += unbranded_wr512-3gn-4m
define Device/unbranded_wr512-3gn-8m
SOC := rt3052
IMAGE_SIZE := 7872k
- DEVICE_VENDOR := Ralink
+ DEVICE_VENDOR := Unbranded
DEVICE_MODEL := WR512-3GN
DEVICE_VARIANT := 8M
SUPPORTED_DEVICES += wr512-3gn-8M
@@ -1104,8 +1104,8 @@ define Device/unbranded_xdx-rn502j
SOC := rt3052
BLOCKSIZE := 64k
IMAGE_SIZE := 3776k
- DEVICE_VENDOR := XDX
- DEVICE_MODEL := RN502J
+ DEVICE_VENDOR := Unbranded
+ DEVICE_MODEL := XDX-RN502J
SUPPORTED_DEVICES += xdxrn502j
DEFAULT := n
endef