aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2019-09-03 23:58:07 +0800
committerChuanhong Guo <gch981213@gmail.com>2019-09-04 19:26:01 +0800
commit7a21c85f7013d75bc1d30a62534a99d5f697f085 (patch)
treee3fb739dd8467f6961fea1cbbf36e903d4f0cd2d /target/linux/ramips/image
parent7290963d0992b9aa412e0066dcf721857fbd40f7 (diff)
downloadupstream-7a21c85f7013d75bc1d30a62534a99d5f697f085.tar.gz
upstream-7a21c85f7013d75bc1d30a62534a99d5f697f085.tar.bz2
upstream-7a21c85f7013d75bc1d30a62534a99d5f697f085.zip
ramips: improve support for Xiaomi Miwifi Nano
This patch does the following things: 1. mark u-boot-env writable 2. add bootcount support Currently, u-boot has a flag_boot_success env variable to reset. Also reset it in our firmware to follow the behavior in vendor's firmware. 3. disable usb support This router doesn't have usb port at all. 4. increase spi clock to 40MHz 5. fix pinmux groups Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt76x8.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 45fed11b54..a602d9df21 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -560,7 +560,7 @@ define Device/xiaomi_miwifi-nano
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Xiaomi
DEVICE_MODEL := MiWiFi Nano
- DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport
+ DEVICE_PACKAGES := uboot-envtools
SUPPORTED_DEVICES += miwifi-nano
endef
TARGET_DEVICES += xiaomi_miwifi-nano