aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorKyoungkyu Park <choryu.park@choryu.space>2021-12-25 04:48:22 +0900
committerSungbo Eo <mans0n@gorani.run>2022-01-15 20:05:46 +0900
commit6041c693dd4660f1585322c182e83479afb3c381 (patch)
tree8cd20014371e868716acca55f8e62a34cd2dd6c7 /target/linux/ramips/image
parent7f7705923a8299323057e78ccae4473b5bb05807 (diff)
downloadupstream-6041c693dd4660f1585322c182e83479afb3c381.tar.gz
upstream-6041c693dd4660f1585322c182e83479afb3c381.tar.bz2
upstream-6041c693dd4660f1585322c182e83479afb3c381.zip
ramips: add support for HUMAX E2
HUMAX E2 (also known as HUMAX QUANTUM E2) is a 2.4/5GHz band AC router, based on MediaTek MT7620A. Specifications: - SoC: MT7620A - RAM: DDR2 64MB - Flash: SPI NOR 8MB (MXIC MX25L6405D) - WiFi: - 2.4GHz: SoC internal - 5GHz: MT7610E - Ethernet: 1x 10/100Mbps - Switch: SoC internal - UART: J2 (57600 8N1) - pinout: [3V3] (RXD) (GND) (TXD) Installation and Recovery via TFTP: 1. Connect ethernet cable between Router port and PC Ethernet port. 2. Set your computer to a static IP **192.168.1.1** 3. Turn the device off and wait a few seconds. Hold the WPS button on front of device and insert power. 4. Send a firmware image to **192.168.1.6** using TFTP. You can use any TFTP client. (tftp, curl, Tftpd64...) 5. Wait until Power LED stop flashing. **DO NOT TURN OFF DEVICE!** The device will be automatically rebooted. Signed-off-by: Kyoungkyu Park <choryu.park@choryu.space>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7620.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index c758da5795..498170236a 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -526,6 +526,20 @@ define Device/hnet_c108
endef
TARGET_DEVICES += hnet_c108
+define Device/humax_e2
+ SOC := mt7620a
+ IMAGE_SIZE := 7744k
+ DEVICE_VENDOR := HUMAX
+ DEVICE_MODEL := E2
+ DEVICE_ALT0_VENDOR := HUMAX
+ DEVICE_ALT0_MODEL := QUANTUM E2
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
+ edimax-header -s CSYS -m RN75 -f 0x70000 -S 0x01100000 | pad-rootfs | \
+ check-size | append-metadata
+ DEVICE_PACKAGES := kmod-mt76x0e
+endef
+TARGET_DEVICES += humax_e2
+
define Device/sunvalley_filehub_common
SOC := mt7620n
IMAGE_SIZE := 6144k