aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2021-12-18 22:19:06 +0900
committerChristian Lamparter <chunkeey@gmail.com>2021-12-29 20:35:57 +0100
commit482a7e23a44c23ea6c6a22e3ea97eb3bf94e70d1 (patch)
tree81512b91147438e09701c96c9763e8dba3d36d3e /target/linux/ramips/image
parent7ea9936f7f32fd90af1a29775ac3b297d7775db7 (diff)
downloadupstream-482a7e23a44c23ea6c6a22e3ea97eb3bf94e70d1.tar.gz
upstream-482a7e23a44c23ea6c6a22e3ea97eb3bf94e70d1.tar.bz2
upstream-482a7e23a44c23ea6c6a22e3ea97eb3bf94e70d1.zip
ramips: add support for WeVO AIR DUO
WeVO AIR DUO is a 1-bay NAS & 802.11ac (Wi-Fi 5) router, based on MediaTek MT7620A. Specifications: * SoC: MT7620A * RAM: 64 MiB * Flash: SPI NOR 16 MiB * USB & SATA bridge controller: JMicron JMS567 * SATA 6Gb/s: 2.5" drive slot * USB 3.0: Micro-B * USB 2.0: connected to SoC * Wi-Fi: * 2.4 GHz: SoC built-in * 5 GHz: MT7612EN * Ethernet: 5x 1GbE * Switch: MT7530WU * UART: 4-pin 1.27 mm pitch through-hole (57600 baud) * Pinout: (3V3)|(RXD) (TXD) (GND) Notes: * The drive is accessible through the external USB port only when the router is turned off. Installation via web interface: 1. Flash **initramfs** image through the stock web interface. The image filename should have ".upload" extension. 2. Boot into OpenWrt and perform sysupgrade with sysupgrade image. Revert to stock firmware: 1. Perform sysupgrade with stock image. Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7620.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index fbf37144b9..c758da5795 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -1160,6 +1160,17 @@ define Device/wavlink_wl-wn579x3
endef
TARGET_DEVICES += wavlink_wl-wn579x3
+define Device/wevo_air-duo
+ SOC := mt7620a
+ IMAGE_SIZE := 15040k
+ UIMAGE_NAME := AIR DUO(0.0.0)
+ KERNEL_INITRAMFS_SUFFIX := .upload
+ DEVICE_VENDOR := WeVO
+ DEVICE_MODEL := AIR DUO
+ DEVICE_PACKAGES := kmod-mt76x2 kmod-usb2 kmod-usb-ohci kmod-usb-storage-uas
+endef
+TARGET_DEVICES += wevo_air-duo
+
define Device/wrtnode_wrtnode
SOC := mt7620n
IMAGE_SIZE := 16064k