aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2022-02-05 19:09:11 +0900
committerSungbo Eo <mans0n@gorani.run>2022-02-11 22:30:04 +0900
commit337e942290fa6a18e0289ae32420c5c402aead1a (patch)
tree6bd1fbe6812173988bbad5ee4bb0c22e3232f371 /target/linux/ramips/image
parent34a373c0df0233150b5c87e9c925ca2b2b754a6e (diff)
downloadupstream-337e942290fa6a18e0289ae32420c5c402aead1a.tar.gz
upstream-337e942290fa6a18e0289ae32420c5c402aead1a.tar.bz2
upstream-337e942290fa6a18e0289ae32420c5c402aead1a.zip
ramips: add support for ELECOM WRC-2533GS2
ELECOM WRC-2533GS2 is a 2.4/5 GHz band 11ac (Wi-Fi 5) router, based on MT7621A. Specification: - SoC : MediaTek MT7621A - RAM : DDR3 128 MiB (NT5CC64M16GP-DI) - Flash : SPI-NOR 16 MiB (MX25L12835FM2I-10G) - WLAN : 2.4/5GHz 4T4R (2x MediaTek MT7615) - Ethernet : 10/100/1000 Mbps x5 - Switch : MediaTek MT7530 (SoC) - LEDs/Keys : 4x/6x (2x buttons, 1x slide-switch) - UART : through-hole on PCB - J4: 3.3V, GND, TX, RX from ethernet port side - 57600n8 - Power : 12 VDC, 1.5 A Flash instruction using factory image: 1. Boot WRC-2533GS2 normally with "Router" mode 2. Access to "http://192.168.2.1/" and open firmware update page ("ファームウェア更新") 3. Select the OpenWrt factory image and click apply ("適用") button 4. Wait ~120 seconds to complete flashing MAC Addresses: LAN : 04:AB:18:xx:xx:FB (Factory, 0xFFF4 (hex)) WAN : 04:AB:18:xx:xx:FC (Factory, 0xFFFA (hex)) 2.4 GHz : 04:AB:18:xx:xx:FD (Factory, 0x4 (hex)) 5 GHz : 04:AB:18:xx:xx:FE (Factory, 0x8004 (hex)) Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 105f1f5b18..8e13920672 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -549,6 +549,14 @@ define Device/elecom_wrc-2533ghbk-i
endef
TARGET_DEVICES += elecom_wrc-2533ghbk-i
+define Device/elecom_wrc-2533gs2
+ $(Device/elecom_wrc-gs)
+ IMAGE_SIZE := 11264k
+ DEVICE_MODEL := WRC-2533GS2
+ ELECOM_HWNAME := WRC-2533GS2
+endef
+TARGET_DEVICES += elecom_wrc-2533gs2
+
define Device/elecom_wrc-2533gst
$(Device/elecom_wrc-gs)
IMAGE_SIZE := 11264k