aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2022-01-29 23:24:07 +0900
committerSungbo Eo <mans0n@gorani.run>2022-01-29 23:50:28 +0900
commit03aa57d7ab7a50ca022a26d087d6c64740232a3b (patch)
tree9b099cef2028348ad4e65d248cf9a742bec7b58d /target/linux/ramips/image
parent6ff970bb51f53c731b0612152734cec82ca92543 (diff)
downloadupstream-03aa57d7ab7a50ca022a26d087d6c64740232a3b.tar.gz
upstream-03aa57d7ab7a50ca022a26d087d6c64740232a3b.tar.bz2
upstream-03aa57d7ab7a50ca022a26d087d6c64740232a3b.zip
ramips: make the relocation address configurable
If no argument is given to relocate-kernel, KERNEL_LOADADDR will be used just as before. This is a preparation for ramips support of ipTIME AX2004M. Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index ac256cf1ae..241b620941 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -113,7 +113,7 @@ endef
define Build/relocate-kernel
rm -rf $@.relocate
$(CP) ../../generic/image/relocate $@.relocate
- $(MAKE) -C $@.relocate KERNEL_ADDR=$(KERNEL_LOADADDR) CROSS_COMPILE=$(TARGET_CROSS)
+ $(MAKE) -C $@.relocate KERNEL_ADDR=$(if $(1),$(1),$(KERNEL_LOADADDR)) CROSS_COMPILE=$(TARGET_CROSS)
( \
dd if=$@.relocate/loader.bin bs=32 conv=sync && \
perl -e '@s = stat("$@"); print pack("V", @s[7])' && \