aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorKyoungkyu Park <choryu.park@choryu.space>2021-11-14 01:03:24 +0900
committerSungbo Eo <mans0n@gorani.run>2021-12-12 20:33:19 +0900
commit9a1b9a42b793104bd65bfd292d4935b061d5da33 (patch)
treeadc9bb19297779557b59b8c86dca80e30b8fe9cc /target/linux/ramips/image
parent91e37b60a0b1181b77aabf7269450bf76d220c40 (diff)
downloadupstream-9a1b9a42b793104bd65bfd292d4935b061d5da33.tar.gz
upstream-9a1b9a42b793104bd65bfd292d4935b061d5da33.tar.bz2
upstream-9a1b9a42b793104bd65bfd292d4935b061d5da33.zip
ramips: add support for HUMAX E10
HUMAX E10 (also known as HUMAX QUANTUM E10) is a 2.4/5GHz band AC router, based on MediaTek MT7621A. Specifications: - SoC: MT7621A - RAM: DDR3 128MB - Flash: SPI NOR 16MB (MXIC MX25L12805D) - WiFi: - 2.4GHz: MT7615 - 5GHz: MT7615 - Ethernet: 2x 10/100/1000Mbps - Switch: SoC internal - USB: 1x USB 2.0 Type-A - UART: J1 (57600 8N1) - pinout: [3V3] (RXD) (GND) (TXD) Installation via web interface: - Flash **factory** image through the stock web interface. Recovery procedure: 1. Connect ethernet cable between Router **LAN** port and PC Ethernet port. 2. Set your computer to a static IP **192.168.1.1** 3. Turn the device off and wait a few seconds. Hold the WPS button on front of device and insert power. 4. Send a firmware image to **192.168.1.6** using TFTP. You can use any TFTP client. (tftp, curl, Tftpd64...) - It can accept both images which is HUMAX stock firmware dump (0x70000-0x1000000) image and OpenWRT **sysupgrade** image. Signed-off-by: Kyoungkyu Park <choryu.park@choryu.space> [remove trailing whitespace] Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 8b156c2a1c..35c5627264 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -637,6 +637,25 @@ define Device/hiwifi_hc5962
endef
TARGET_DEVICES += hiwifi_hc5962
+define Device/humax_e10
+ $(Device/dsa-migration)
+ $(Device/uimage-lzma-loader)
+ IMAGE_SIZE := 15936k
+ DEVICE_VENDOR := HUMAX
+ DEVICE_MODEL := E10
+ DEVICE_ALT0_VENDOR := HUMAX
+ DEVICE_ALT0_MODEL := QUANTUM E10
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
+ edimax-header -s CSYS -m EA03 -f 0x70000 -S 0x01100000 | pad-rootfs | \
+ check-size | append-metadata
+ IMAGES += factory.bin
+ IMAGE/factory.bin := append-kernel | append-rootfs | pad-rootfs | \
+ edimax-header -s CSYS -m EA03 -f 0x70000 -S 0x01100000 | \
+ check-size | zip upg -P f013c26cf0a320fb71d03356dcb6bb63
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware kmod-usb3
+endef
+TARGET_DEVICES += humax_e10
+
define Device/iodata_wn-ax1167gr
$(Device/dsa-migration)
$(Device/uimage-lzma-loader)