aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorRodolphe de Saint Léger <rdesaintleger@gmail.com>2022-03-16 10:19:30 +0100
committerSungbo Eo <mans0n@gorani.run>2022-03-16 22:36:04 +0900
commit7bc20cb6143e089fae6ad4b173fc42b55bdbecfe (patch)
treeb480155ec15e9c06df6e0b6ac7f471c3a62ea862 /target/linux/ramips/image
parentbe89c9eec4c28123b61ed020ad5b8b02905e73af (diff)
downloadupstream-7bc20cb6143e089fae6ad4b173fc42b55bdbecfe.tar.gz
upstream-7bc20cb6143e089fae6ad4b173fc42b55bdbecfe.tar.bz2
upstream-7bc20cb6143e089fae6ad4b173fc42b55bdbecfe.zip
ramips: add support for Netgear WN3000RPv3
This patch adds support for the Netgear WN3100RPv2 http://www.netgear.com/support/product/wn3100rpv2.aspx Specifications: - SoC: MediaTek MT7620A (580MHz, ramips) - RAM: 32MB DDR - Storage: 8MB NOR SPI flash - Wireless: builtin MT7620A, 2x2:2 with u.FL connectors - Ethernet: 1x100M - Stock firmware based on OpenWRT Kamikaze Like the EX2700, the bootloader expects a secondary image signature, see https://forum.openwrt.org/viewtopic.php?pid=312577#p312577 This device seems to be same hardware as a WN3000RPv3 Flash instructions: - Use the Netgear WebUI to upgrade to OpenWRT using the factory image (see note below), - Use the sysupgrade image for upgrading versions from OpenWRT, - TFTP recovery procedure can be used to flash the factory image (preferred method). Note: - The WebUI may not reboot automatically, wait at least 5 minutes before powercycling the device Flashing using TFTP: - Set you IP address to 192.168.1.10/24 (no gateway) - Connect your machine to the Ethernet port - Power off the device and wait for 10 seconds, - Hold the reset button and power on the device (do not release reset), - Hold the reset button until the green light is flashing (Approx. 15s) - launch tftp, set mode to binary and connect to 192.168.1.1 - put the factory firmware image - All leds will switch off (like a power off), this is normal - Wait for the device to reboot in the new OpenWRT image (max 5 mins) - The first boot will take longer than usual. - After boot, the Device IP on the ethernet port is 192.168.1.1 Signed-off-by: Rodolphe de Saint Léger <rdesaintleger@gmail.com> [drop unneeded includes in dts, wrap commit message] Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7620.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 49d25b947f..d2a2c90460 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -819,6 +819,22 @@ define Device/netgear_wn3000rp-v3
endef
TARGET_DEVICES += netgear_wn3000rp-v3
+define Device/netgear_wn3100rp-v2
+ SOC := mt7620a
+ IMAGE_SIZE := 7872k
+ NETGEAR_HW_ID := 29764883+8+0+32+2x2+0
+ NETGEAR_BOARD_ID := WN3100RPv2
+ BLOCKSIZE := 4k
+ IMAGES += factory.bin
+ KERNEL := $(KERNEL_DTB) | uImage lzma | pad-offset 64k 64 | \
+ append-uImage-fakehdr filesystem
+ IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | netgear-dni
+ DEVICE_VENDOR := NETGEAR
+ DEVICE_MODEL := WN3100RP
+ DEVICE_VARIANT := v2
+endef
+TARGET_DEVICES += netgear_wn3100rp-v2
+
define Device/netis_wf2770
SOC := mt7620a
IMAGE_SIZE := 16064k