aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2021-06-01 21:09:26 +0000
committerAlexander Couzens <lynxis@fe80.eu>2021-09-21 14:08:51 +0200
commit7f7bf36ec5bacbf414615d3cde009be548a86ae0 (patch)
tree25c518c20c209dbb5b96be9051b0050097586a46 /target/linux/ramips/image
parenta44fd27070e9fbd41dfa25585520f4b8937471cf (diff)
downloadupstream-7f7bf36ec5bacbf414615d3cde009be548a86ae0.tar.gz
upstream-7f7bf36ec5bacbf414615d3cde009be548a86ae0.tar.bz2
upstream-7f7bf36ec5bacbf414615d3cde009be548a86ae0.zip
ramips: add support for minew g1-c
The minew g1-c is a smart home gateway / BLE gateway. A Nordic nRF52832 is available via USB UART (cp210x) to support BLE. The LED ring is a ring of 24x ws2812b connect to a generic GPIO (unsupported). There is a small LED which is only visible when the device is open which will be used as LED until the ws2812b is supported. The board has also a micro sdcard/tfcard slot (untested). The Nordic nRF52832 exposes SWD over a 5pin header (GND, VCC, SWD, SWC, RST). The vendor uses an older OpenWrt version, sysupgrade can be used via serial or ssh. CPU: MT7628AN / 580MHz RAM: DDR2 128 MiB RAM Flash: SPI NOR 16 MiB W25Q128 Ethernet: 1x 100 mbit (Port 0) (PoE in) USB: USB hub, 2x external, 1x internal to USB UART Power: via micro usb or PoE 802.11af UART: 3.3V, 115200 8n1 Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt76x8.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index c5a0baa1cb..1a75bab377 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -269,6 +269,15 @@ define Device/mercury_mac1200r-v2
endef
TARGET_DEVICES += mercury_mac1200r-v2
+define Device/minew_g1-c
+ IMAGE_SIZE := 15744k
+ DEVICE_VENDOR := Minew
+ DEVICE_MODEL := G1-C
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport kmod-usb-serial-cp210x
+ SUPPORTED_DEVICES += minew-g1c
+endef
+TARGET_DEVICES += minew_g1-c
+
define Device/netgear_r6020
$(Device/netgear_sercomm_nor)
IMAGE_SIZE := 7104k