aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorLeon M. George <leon@georgemail.eu>2020-12-24 11:32:47 +0100
committerPetr Štetiar <ynezz@true.cz>2021-06-10 17:09:35 +0200
commitd11f40a0f75bddb1339c6a0423553080acaeb75e (patch)
tree72ef65b18bbaf085411ab5e4a903f58552b2bda4 /target/linux/ramips/image
parent31be36126929751ac90ad6ff74a1df32feeb8e21 (diff)
downloadupstream-d11f40a0f75bddb1339c6a0423553080acaeb75e.tar.gz
upstream-d11f40a0f75bddb1339c6a0423553080acaeb75e.tar.bz2
upstream-d11f40a0f75bddb1339c6a0423553080acaeb75e.zip
ramips: add support for cudy WR2100
Specifications SoC: MT7621 CPU: 880 MHz Flash: 16 MiB RAM: 128 MiB WLAN: 2.4 GHz b/g/n, 5 GHz a/n/ac MT7603E / MT7615E Ethernet: 5x Gbit ports Installation There are two known options: 1) The Luci-based UI. 2) Press and hold the reset button during power up. The router will request 'recovery.bin' from a TFTP server at 192.168.1.88. Both options require a signed firmware binary. The openwrt image supplied by cudy is signed and can be used to install unsigned images. R4 & R5 need to be shorted (0-100Ω) for the UART to work. Signed-off-by: Leon M. George <leon@georgemail.eu> [remove non-required switch-port node - remove trgmii phy-mode] Signed-off-by: David Bauer <mail@david-bauer.net> (cherry picked from commit 3501db9b9b4a71ae52c539b46af817783c327866)
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index d56067948e..0ec283d74f 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -240,6 +240,16 @@ define Device/cudy_wr1300
endef
TARGET_DEVICES += cudy_wr1300
+define Device/cudy_wr2100
+ $(Device/dsa-migration)
+ DEVICE_VENDOR := Cudy
+ DEVICE_MODEL := WR2100
+ IMAGE_SIZE := 15872k
+ UIMAGE_NAME := R11
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e kmod-mt7615-firmware
+endef
+TARGET_DEVICES += cudy_wr2100
+
define Device/dlink_dir-8xx-a1
$(Device/dsa-migration)
IMAGE_SIZE := 16000k