aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-07-03 23:22:34 +0200
committerDaniel Golle <daniel@makrotopia.org>2019-07-10 17:36:29 +0200
commit6a104ac77206158c593cc7572c46eca6d3f4717f (patch)
tree3f66a84c3dfb87dfc3db93797b04f7c84cae5080 /target/linux/ramips/image
parentb97a99256fe54e81c8fc6c60183f46fbf731bbf8 (diff)
downloadupstream-6a104ac77206158c593cc7572c46eca6d3f4717f.tar.gz
upstream-6a104ac77206158c593cc7572c46eca6d3f4717f.tar.bz2
upstream-6a104ac77206158c593cc7572c46eca6d3f4717f.zip
ramips/rt288x,rt3883: Name DTS files based on scheme
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/rt288x.mk16
-rw-r--r--target/linux/ramips/image/rt3883.mk20
2 files changed, 18 insertions, 18 deletions
diff --git a/target/linux/ramips/image/rt288x.mk b/target/linux/ramips/image/rt288x.mk
index fe6764ce59..e8e51adc31 100644
--- a/target/linux/ramips/image/rt288x.mk
+++ b/target/linux/ramips/image/rt288x.mk
@@ -10,7 +10,7 @@ define Build/gemtek-header
endef
define Device/airlink101_ar670w
- DTS := AR670W
+ MTK_SOC := rt2880
BLOCKSIZE := 64k
DEVICE_VENDOR := Airlink
DEVICE_MODEL := AR670W
@@ -24,7 +24,7 @@ endef
TARGET_DEVICES += airlink101_ar670w
define Device/airlink101_ar725w
- DTS := AR725W
+ MTK_SOC := rt2880
DEVICE_VENDOR := Airlink
DEVICE_MODEL := AR725W
IMAGES += factory.bin
@@ -35,7 +35,7 @@ endef
TARGET_DEVICES += airlink101_ar725w
define Device/dlink_dap-1522-a1
- DTS := DAP-1522-A1
+ MTK_SOC := rt2880
BLOCKSIZE := 64k
IMAGE_SIZE := 3801088
DEVICE_VENDOR := D-Link
@@ -53,7 +53,7 @@ endef
TARGET_DEVICES += dlink_dap-1522-a1
define Device/belkin_f5d8235-v1
- DTS := F5D8235_V1
+ MTK_SOC := rt2880
IMAGE_SIZE := 7744k
DEVICE_VENDOR := Belkin
DEVICE_MODEL := F5D8235
@@ -65,7 +65,7 @@ endef
TARGET_DEVICES += belkin_f5d8235-v1
define Device/asus_rt-n15
- DTS := RT-N15
+ MTK_SOC := rt2880
BLOCKSIZE := 64k
IMAGE_SIZE := $(ralink_default_fw_size_4M)
DEVICE_VENDOR := Asus
@@ -76,7 +76,7 @@ endef
TARGET_DEVICES += asus_rt-n15
define Device/ralink_v11st-fe
- DTS := V11STFE
+ MTK_SOC := rt2880
BLOCKSIZE := 64k
IMAGE_SIZE := $(ralink_default_fw_size_4M)
DEVICE_VENDOR := Ralink
@@ -86,7 +86,7 @@ endef
TARGET_DEVICES += ralink_v11st-fe
define Device/buffalo_wli-tx4-ag300n
- DTS := WLI-TX4-AG300N
+ MTK_SOC := rt2880
BLOCKSIZE := 64k
IMAGE_SIZE := $(ralink_default_fw_size_4M)
DEVICE_VENDOR := Buffalo
@@ -97,7 +97,7 @@ endef
TARGET_DEVICES += buffalo_wli-tx4-ag300n
define Device/buffalo_wzr-agl300nh
- DTS := WZR-AGL300NH
+ MTK_SOC := rt2880
BLOCKSIZE := 64k
IMAGE_SIZE := $(ralink_default_fw_size_4M)
DEVICE_VENDOR := Buffalo
diff --git a/target/linux/ramips/image/rt3883.mk b/target/linux/ramips/image/rt3883.mk
index 9e1d928603..0adb39eab1 100644
--- a/target/linux/ramips/image/rt3883.mk
+++ b/target/linux/ramips/image/rt3883.mk
@@ -6,7 +6,7 @@ define Build/mkrtn56uimg
endef
define Device/edimax_br-6475nd
- DTS := BR-6475ND
+ MTK_SOC := rt3883
BLOCKSIZE := 64k
IMAGE_SIZE := 7744k
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
@@ -21,7 +21,7 @@ TARGET_DEVICES += edimax_br-6475nd
define Device/samsung_cy-swr1100
$(Device/seama)
- DTS := CY-SWR1100
+ MTK_SOC := rt3883
BLOCKSIZE := 64k
KERNEL := $(KERNEL_DTB)
SEAMA_SIGNATURE := wrgnd10_samsung_ss815
@@ -35,7 +35,7 @@ TARGET_DEVICES += samsung_cy-swr1100
define Device/dlink_dir-645
$(Device/seama)
- DTS := DIR-645
+ MTK_SOC := rt3883
BLOCKSIZE := 4k
KERNEL := $(KERNEL_DTB)
SEAMA_SIGNATURE := wrgn39_dlob.hans_dir645
@@ -48,7 +48,7 @@ TARGET_DEVICES += dlink_dir-645
define Device/belkin_f9k1109v1
- DTS := F9K1109V1
+ MTK_SOC := rt3883
BLOCKSIZE := 64k
DEVICE_VENDOR := Belkin
DEVICE_MODEL := F9K1109
@@ -62,7 +62,7 @@ endef
TARGET_DEVICES += belkin_f9k1109v1
define Device/omnima_hpm
- DTS := HPM
+ MTK_SOC := rt3883
BLOCKSIZE := 64k
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Omnima
@@ -74,7 +74,7 @@ TARGET_DEVICES += omnima_hpm
define Device/asus_rt-n56u
- DTS := RT-N56U
+ MTK_SOC := rt3883
BLOCKSIZE := 64k
IMAGE/sysupgrade.bin += | mkrtn56uimg -s
DEVICE_VENDOR := Asus
@@ -86,7 +86,7 @@ TARGET_DEVICES += asus_rt-n56u
define Device/trendnet_tew-691gr
- DTS := TEW-691GR
+ MTK_SOC := rt3883
BLOCKSIZE := 64k
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
@@ -100,7 +100,7 @@ TARGET_DEVICES += trendnet_tew-691gr
define Device/trendnet_tew-692gr
- DTS := TEW-692GR
+ MTK_SOC := rt3883
BLOCKSIZE := 64k
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
@@ -114,7 +114,7 @@ TARGET_DEVICES += trendnet_tew-692gr
define Device/sitecom_wlr-6000
- DTS := WLR-6000
+ MTK_SOC := rt3883
BLOCKSIZE := 4k
IMAGE_SIZE := 7244k
IMAGES += factory.dlf
@@ -129,7 +129,7 @@ TARGET_DEVICES += sitecom_wlr-6000
define Device/loewe_wmdr-143n
- DTS := WMDR-143N
+ MTK_SOC := rt3883
BLOCKSIZE := 64k
DEVICE_VENDOR := Loewe
DEVICE_MODEL := WMDR-143N