aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorThomas Vincent-Cross <me@tvc.id.au>2018-10-23 02:21:16 +1100
committerMathias Kresin <dev@kresin.me>2018-11-28 00:50:35 +0100
commita160f50d4f240019fafe95e80701ebb871c788fe (patch)
tree5d7badd6dbe43f0c543dbdf3f65f0d6052d2248a /target/linux/ramips/image
parent31469aebd4c737ba891ceffc58db59c6b039445c (diff)
downloadupstream-a160f50d4f240019fafe95e80701ebb871c788fe.tar.gz
upstream-a160f50d4f240019fafe95e80701ebb871c788fe.tar.bz2
upstream-a160f50d4f240019fafe95e80701ebb871c788fe.zip
ramips: add support for Wavlink WL-WN570HA1
This commit adds support for the Wavlink WL-WN570HA1, a dual-band PoE wireless router with the following specifications: - CPU: MediaTek MT7688AN 580MHz - Flash: 8MB - RAM: 64MB - Ethernet: 1x 10/100Mbps - 2.4 GHz: 802.11b/g/n SoC, 1T1R, 27 dBm - 5 GHz: 802.11a/n/ac MT7610E, 1T1R, 25 dBm - Antennas: 2x external (1 per radio), detachable - LEDs: 3 programmable + Wi-Fi, WAN/LAN, Power - Buttons: Reset Flashing instructions: Factory U-boot launches a TFTP client if reset button is pressed during power-on. Rename the sysupgrade file and configure TFTP as follows: - Client (WL-WN570HA1) IP: 192.168.10.101 - Server IP: 192.168.10.100 - Filename: firmware.bin Signed-off-by: Thomas Vincent-Cross <me@tvc.id.au> [use generic board detection, add firmware partition compatible] Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt76x8.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 3174988f49..af5b0f6d60 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -321,6 +321,14 @@ define Device/vocore2lite
endef
TARGET_DEVICES += vocore2lite
+define Device/wavlink_wl-wn570ha1
+ DTS := WL-WN570HA1
+ IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ DEVICE_TITLE := Wavlink WL-WN570HA1
+ DEVICE_PACKAGES := kmod-mt76x0e
+endef
+TARGET_DEVICES += wavlink_wl-wn570ha1
+
define Device/wcr-1166ds
DTS := WCR-1166DS
BUFFALO_TAG_PLATFORM := MTK