aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorNicholas Smith <mips171@icloud.com>2019-04-19 14:12:11 +1000
committerChristian Lamparter <chunkeey@gmail.com>2019-05-18 17:59:49 +0200
commit73e0f52b6e4e1c79e4e95573f2050ae9ff10ac00 (patch)
tree7d4cb49b09384b3d8c82cbe798149b680b2382f2 /target/linux/ramips/image
parentf5d2c91415a68f554815860d574145644fc31c16 (diff)
downloadupstream-73e0f52b6e4e1c79e4e95573f2050ae9ff10ac00.tar.gz
upstream-73e0f52b6e4e1c79e4e95573f2050ae9ff10ac00.tar.bz2
upstream-73e0f52b6e4e1c79e4e95573f2050ae9ff10ac00.zip
ramips: add support for Telco Electronics X1
Hardware: SoC: MT7621 DRAM: 256MB DDR3 Flash: 16MB SPI-NOR WiFi: 2.4GHz: MT7603 @ PCIe0 WiFi: 5.8GHz: MT7612 @ PCIe1 Modem: Sierra Wireless MC74xx Interfaces: GBE RJ45 x5 mPCIe x2 UART x1 I2C x1 JTAG x1 UIM x1 LEDs x6 Flash instructions: Flash from within the factory bootloader, firmware web interface or CLI using sysupgrade -F -n Signed-off-by: Nicholas Smith <mips171@icloud.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 671e7f378a..c21b9b4b63 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -435,6 +435,14 @@ define Device/sk-wb8
endef
TARGET_DEVICES += sk-wb8
+define Device/telco-electronics_x1
+ DTS := Telco-Electronics-X1
+ IMAGE_SIZE := 16064k
+ DEVICE_TITLE := Telco Electronics X1
+ DEVICE_PACKAGES := kmod-usb3 kmod-mt76 wpad-basic
+endef
+TARGET_DEVICES += telco-electronics_x1
+
define Device/timecloud
DTS := Timecloud
DEVICE_TITLE := Thunder Timecloud