aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2019-07-03 14:50:14 +0200
committerDavid Bauer <mail@david-bauer.net>2019-07-21 13:10:12 +0200
commitabe137ff5ee322321a7905e73f084514f2e86b38 (patch)
treedbb48c518039aa6aed7e46ee8102967055f6609f /target/linux/ramips/image
parent5cd9b50d69cb42d55b9cc466b749b41d1da465de (diff)
downloadupstream-abe137ff5ee322321a7905e73f084514f2e86b38.tar.gz
upstream-abe137ff5ee322321a7905e73f084514f2e86b38.tar.bz2
upstream-abe137ff5ee322321a7905e73f084514f2e86b38.zip
ramips: add support for ASUS RT-AC57U
SoC: MediaTek MT7621AT RAM: 128M (Winbond W631GG6KB-15) FLASH: 16MB (Spansion S25FL128SA) WiFi: MediaTek MT7603EN bgn 2SS WiFi: MediaTek MT7612EN nac 2SS BTN: Reset - WPS LED: - Power - LAN {1-4} - WAN - WiFi 2.4 GHz - WiFi 5 GHz - USB UART: UART is present next to the Power LED. TX - RX - GND - 3V3 / 57600-8N1 3V3 is the nearest one to the Power LED. Installation ------------ Via TFTP: 1. Set your computers IP-Address to 192.168.1.75. 2. Power up the Router with the Reset button pressed. 3. Release the Reset button after 5 seconds. 4. Upload OpenWRT sysupgrade image via TFTP: > tftp -4 -v -m binary 192.168.1.1 -c put <IMAGE> Via SSH: Note: User/password for SSH is identical with the one used in the Web-interface. 1. Complete the initial setup wizard. 2. Activate SSH under "Administration" -> "System". 3. Transfer the OpenWrt sysupgrade image via scp: > scp owrt.bin admin@192.168.1.1:/tmp 4. Connect via SSH to the router. > ssh admin@192.168.1.1 5. Write the OpenWrt image to flash. > mtd-write -i /tmp/owrt.bin -d linux 6. Reboot the router > reboot Signed-off-by: David Bauer <mail@david-bauer.net> (cherry picked from commit 14e0e4f138e35c3e2a15cc3a836c939547ee053b)
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 2eb7feb5bf..d125fdc04d 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -92,6 +92,14 @@ define Device/11acnas
endef
TARGET_DEVICES += 11acnas
+define Device/asus_rt-ac57u
+ DTS := RT-AC57U
+ DEVICE_TITLE := ASUS RT-AC57U
+ IMAGE_SIZE := 16064k
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+endef
+TARGET_DEVICES += asus_rt-ac57u
+
define Device/dir-860l-b1
$(Device/seama)
DTS := DIR-860L-B1