aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorMarkus Scheck <markus@mscheck.de>2019-05-27 19:25:22 +0200
committerChristian Lamparter <chunkeey@gmail.com>2019-05-31 11:21:22 +0200
commit5ff5c9bce6b6e51060c272521528b5afd789e9ab (patch)
tree081c216ed91f205fdfe45c76c6c802cb3e199dcd /target/linux/ramips/image
parenta41f474d17fef8aa94fdd6a8aa9b9a4bd2e5fa0f (diff)
downloadupstream-5ff5c9bce6b6e51060c272521528b5afd789e9ab.tar.gz
upstream-5ff5c9bce6b6e51060c272521528b5afd789e9ab.tar.bz2
upstream-5ff5c9bce6b6e51060c272521528b5afd789e9ab.zip
ramips: add support for Xiaomi Mi Router 4A (100M Edition)
- SoC: MediaTek MT7628AN - Flash: 16MB (Winbond W25Q128JV) - RAM: 64MB - Serial: As marked on PCB, 3V3 logic, baudrate is 115200 - Ethernet: 3x 10/100 Mbps (switched, 2x LAN + WAN) - WIFI0: MT7628AN 2.4GHz 802.11b/g/n - WIFI1: MT7612EN 5GHz 802.11ac - Antennas: 4x external (2 per radio), non-detachable - LEDs: Programmable power-LED (two-colored, yellow/blue) Non-programmable internet-LED (shows WAN-activity) - Buttons: Reset INSTALLATION: 1. Connect to the serial port of the router and power it up. If you get a prompt asking for boot-mode, go to step 3. 2. Unplug the router after > Erasing SPI Flash... > raspi_erase: offs:20000 len:10000 occurs on the serial port. Plug the router back in. 3. At the prompt select option 2 (Load system code then write to Flash via TFTP.) 4. Enter 192.168.1.1 as the device IP and 192.168.1.2 as the Server-IP. 5. Connect your computer to LAN1 and assign it as 192.168.1.2/24. 6. Rename the sysupgrade image to test.bin and serve it via TFTP. 7. Enter test.bin on the serial console and press enter. Signed-off-by: Markus Scheck <markus@mscheck.de> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [added mt76 compatible]
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt76x8.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index ca279a7d61..4e6a5d1ca9 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -450,6 +450,14 @@ define Device/wrtnode2r
endef
TARGET_DEVICES += wrtnode2r
+define Device/xiaomi_mir4a-100m
+ DTS := XIAOMI-MIR4A-100M
+ IMAGE_SIZE := 14976k
+ DEVICE_TITLE := Xiaomi Mi Router 4A (100M Edition)
+ DEVICE_PACKAGES := kmod-mt76x2
+endef
+TARGET_DEVICES += xiaomi_mir4a-100m
+
define Device/zbtlink_zbt-we1226
DTS := ZBT-WE1226
IMAGE_SIZE := $(ralink_default_fw_size_8M)