aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorRoman Yeryomin <roman@advem.lv>2018-02-22 18:08:14 +0200
committerFelix Fietkau <nbd@nbd.name>2018-02-24 16:05:28 +0100
commitf5984e0a0c8e2dae39fb381a6b7d209beba7fc3c (patch)
treebc56883f51cf7ec40f48aee04abbb92113e913ed /target/linux/ramips/image
parentbcf4a5f474d1899af65f0974914f737bf9a8d9dd (diff)
downloadupstream-f5984e0a0c8e2dae39fb381a6b7d209beba7fc3c.tar.gz
upstream-f5984e0a0c8e2dae39fb381a6b7d209beba7fc3c.tar.bz2
upstream-f5984e0a0c8e2dae39fb381a6b7d209beba7fc3c.zip
ramips: mt7621: add Mediatek AP-MT7621A-V60 EVB support
This board has: - mt7621 SoC - 8MB SPI flash - 128MB RAM - 5x ethernet ports from internal (SoC) switch - 1x ethernet port sitting on gmac2 and IC+ phy (not yet supported) - 3x PCIe slots - 1x USB 2.0 and 1x USB 3.0 - sound based on wm8960 - SDXC card slot (full size) First fw write from interactive u-boot menu, interrupt with 2. After that sysupgrade. Tested both with 4.9 and 4.14 Signed-off-by: Roman Yeryomin <roman@advem.lv>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index d3dfb237b6..18b6934529 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -57,6 +57,14 @@ define Device/dir-860l-b1
endef
TARGET_DEVICES += dir-860l-b1
+define Device/mediatek_ap-mt7621a-v60
+ DTS := AP-MT7621A-V60
+ IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ DEVICE_TITLE := Mediatek AP-MT7621A-V60 EVB
+ DEVICE_PACKAGES := kmod-usb3 kmod-sdhci-mt7620 kmod-sound-mt7620
+endef
+TARGET_DEVICES += mediatek_ap-mt7621a-v60
+
define Device/ew1200
DTS := EW1200
IMAGE_SIZE := $(ralink_default_fw_size_16M)