aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorYuheiOKAWA <tochiro.srchack@gmail.com>2018-02-23 01:58:23 +0900
committerJohn Crispin <john@phrozen.org>2018-05-24 17:24:30 +0200
commit0f35193aecff47bb7a233a1123c87c1b8a9b2a04 (patch)
tree45e2ee9aa7f1491ca594eaa4b0a9a76fb64833ea /target/linux/ramips/image
parent1780f09ee377fb3c75969cd5ebfffc169423364d (diff)
downloadupstream-0f35193aecff47bb7a233a1123c87c1b8a9b2a04.tar.gz
upstream-0f35193aecff47bb7a233a1123c87c1b8a9b2a04.tar.bz2
upstream-0f35193aecff47bb7a233a1123c87c1b8a9b2a04.zip
ramips: add support for YUKAI Engineering Inc. BOCCO
BOCCO is a communication robot provided by YUKAI Engineering Inc. SoC: MT7620A MEM: 256MB Flash: 8MB NAND: 512MB (non support) Include Sound DAC and AMP. No Wired Ethernet. Signed-off-by: YuheiOKAWA <tochiro.srchack@gmail.com> (cherry picked from commit d91953cb5351f1ab3e75ae9e2d9622f754d518ed)
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7620.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 6ddbf066df..8081d906f6 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -83,6 +83,13 @@ define Device/ArcherMR200
endef
TARGET_DEVICES += ArcherMR200
+define Device/bocco
+ DTS := BOCCO
+ DEVICE_TITLE := YUKAI Engineering BOCCO
+ DEVICE_PACKAGES := kmod-sound-core kmod-sound-mt7620 kmod-i2c-ralink
+endef
+TARGET_DEVICES += bocco
+
define Device/c108
DTS := C108
IMAGE_SIZE := 16777216