aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorYuheiOKAWA <tochiro.srchack@gmail.com>2018-02-23 01:58:23 +0900
committerJohn Crispin <john@phrozen.org>2018-05-18 11:19:00 +0200
commitd91953cb5351f1ab3e75ae9e2d9622f754d518ed (patch)
treef05912d0ae47c473562863f5c66bdbc6a7597aba /target/linux/ramips/image
parent45dc530334d8694a962d0833432effd14fa5cc4a (diff)
downloadupstream-d91953cb5351f1ab3e75ae9e2d9622f754d518ed.tar.gz
upstream-d91953cb5351f1ab3e75ae9e2d9622f754d518ed.tar.bz2
upstream-d91953cb5351f1ab3e75ae9e2d9622f754d518ed.zip
ramips: add support for YUKAI Engineering Inc. BOCCO
BOCCO is a communication robot provided by YUKAI Engineering Inc. SoC: MT7620A MEM: 256MB Flash: 8MB NAND: 512MB (non support) Include Sound DAC and AMP. No Wired Ethernet. Signed-off-by: YuheiOKAWA <tochiro.srchack@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7620.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 6ddbf066df..8081d906f6 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -83,6 +83,13 @@ define Device/ArcherMR200
endef
TARGET_DEVICES += ArcherMR200
+define Device/bocco
+ DTS := BOCCO
+ DEVICE_TITLE := YUKAI Engineering BOCCO
+ DEVICE_PACKAGES := kmod-sound-core kmod-sound-mt7620 kmod-i2c-ralink
+endef
+TARGET_DEVICES += bocco
+
define Device/c108
DTS := C108
IMAGE_SIZE := 16777216