aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-11-12 21:35:01 +0000
committerJohn Crispin <john@openwrt.org>2012-11-12 21:35:01 +0000
commitced0cf3a94053f43671e2e46fbba45f0214f9741 (patch)
tree64ffee24b91f9552b41521ec2016502d72ff079e /target/linux/ramips/image
parent31541f81c36c2b2d0c40083623586fc0100db8d6 (diff)
downloadupstream-ced0cf3a94053f43671e2e46fbba45f0214f9741.tar.gz
upstream-ced0cf3a94053f43671e2e46fbba45f0214f9741.tar.bz2
upstream-ced0cf3a94053f43671e2e46fbba45f0214f9741.zip
move ethernet hw init to init/uninit functions
This should fix the stalled irq problem seen by several people. This is not the real fix, but rather moves the bug to the un/init patch of the driver. The real bug still needs to be fixed, but this workaround should be suffcient to make the ethernet stable. SVN-Revision: 34177
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 6509e2deaf..5dd6938330 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -126,9 +126,9 @@ define BuildFirmware/GENERIC_4M/initramfs
$(call BuildFirmware/Generic/initramfs,$(1),$(2),$(call mkcmdline,$(3),$(4),$(5)) $(call mkmtd/$(6),$(mtdlayout_4M)))
endef
-mtdlayout_8M=192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,896k(kernel),6976k(rootfs),7872k@0x50000(firmware)
-kernel_size_8M=917504
-rootfs_size_8M=7143424
+mtdlayout_8M=192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,960k(kernel),6912k(rootfs),7808k@0x50000(firmware)
+kernel_size_8M=983040
+rootfs_size_8M=7077888
define BuildFirmware/GENERIC_8M
$(call BuildFirmware/Generic,$(1),$(2),$(call mkcmdline,$(3),$(4),$(5)) $(call mkmtd/$(6),$(mtdlayout_8M)),$(kernel_size_8M),$(rootfs_size_8M))
endef