aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2018-07-26 23:24:22 +0900
committerJohn Crispin <john@phrozen.org>2018-07-30 15:55:21 +0200
commitce93445cd6058ae37ca3d257792f68cd98e758da (patch)
tree1eddc84811b79ffc8721553ddac0ddf8a682743d /target/linux/ramips/image
parent869b0d11db926a925bff6bad6024a0031bb259ac (diff)
downloadupstream-ce93445cd6058ae37ca3d257792f68cd98e758da.tar.gz
upstream-ce93445cd6058ae37ca3d257792f68cd98e758da.tar.bz2
upstream-ce93445cd6058ae37ca3d257792f68cd98e758da.zip
ramips: add support for ELECOM WRC-2533GST
ELECOM WRC-2533GST is a 2.4/5 GHz band 11ac rotuer, based on MediaTek MT7621A. Specification: - MT7621A (2-Core, 4-Threads) - 128 MB of RAM (DDR3) - 16 MB of Flash (SPI) - 4T4R 2.4/5 GHz wifi - MediaTek MT7615 - 5x 10/100/1000 Mbps Ethernet - 4x LEDs, 6 keys (2x buttons, 1x slide switch) - UART header on PCB - Vcc, GND, TX, RX from ethernet port side - baudrate: 57600 bps Flash instruction using factory image: 1. Connect the computer to the LAN port of WRC-2533GST 2. Connect power cable to WRC-2533GST and turn on it 3. Access to "https://192.168.2.1/" and open firmware update page ("ファームウェア更新") 4. Select the OpenWrt factory image and click apply ("適用") button 5. Wait ~150 seconds to complete flashing Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 8ac78ad7de..b427ff4f25 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -4,6 +4,19 @@
DEVICE_VARS += TPLINK_BOARD_ID TPLINK_HEADER_VERSION TPLINK_HWID TPLINK_HWREV
+define Build/elecom-gst-factory
+ $(eval product=$(word 1,$(1)))
+ $(eval version=$(word 2,$(1)))
+ ( $(STAGING_DIR_HOST)/bin/mkhash md5 $@ | tr -d '\n' ) >> $@
+ ( \
+ echo -n "ELECOM $(product) v$(version)" | \
+ dd bs=32 count=1 conv=sync; \
+ dd if=$@; \
+ ) > $@.new
+ mv $@.new $@
+ echo -n "MT7621_ELECOM_$(product)" >> $@
+endef
+
define Build/elecom-wrc-factory
$(eval product=$(word 1,$(1)))
$(eval version=$(word 2,$(1)))
@@ -104,6 +117,16 @@ define Device/elecom_wrc-1167ghbk2-s
endef
TARGET_DEVICES += elecom_wrc-1167ghbk2-s
+define Device/elecom_wrc-2533gst
+ DTS := WRC-2533GST
+ IMAGE_SIZE := 11264k
+ DEVICE_TITLE := ELECOM WRC-2533GST
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) |\
+ elecom-gst-factory WRC-2533GST 0.00
+endef
+TARGET_DEVICES += elecom_wrc-2533gst
+
define Device/ew1200
DTS := EW1200
IMAGE_SIZE := $(ralink_default_fw_size_16M)