aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-07-03 23:22:16 +0200
committerDaniel Golle <daniel@makrotopia.org>2019-07-10 17:36:29 +0200
commit83efa8329b35a1a2688309323169fa624cec4e5c (patch)
treef32718e54dca7bd8d9b7ebea8edc10d5024f8081 /target/linux/ramips/image
parentc2334ad60dc82cedc2ec9a6eb8166200d7cbf5e3 (diff)
downloadupstream-83efa8329b35a1a2688309323169fa624cec4e5c.tar.gz
upstream-83efa8329b35a1a2688309323169fa624cec4e5c.tar.bz2
upstream-83efa8329b35a1a2688309323169fa624cec4e5c.zip
ramips/rt288x,rt3883: Synchronize Makefiles with DTS compatible
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/rt288x.mk35
-rw-r--r--target/linux/ramips/image/rt3883.mk45
2 files changed, 48 insertions, 32 deletions
diff --git a/target/linux/ramips/image/rt288x.mk b/target/linux/ramips/image/rt288x.mk
index 22fe4a857a..fe6764ce59 100644
--- a/target/linux/ramips/image/rt288x.mk
+++ b/target/linux/ramips/image/rt288x.mk
@@ -9,7 +9,7 @@ define Build/gemtek-header
fi
endef
-define Device/ar670w
+define Device/airlink101_ar670w
DTS := AR670W
BLOCKSIZE := 64k
DEVICE_VENDOR := Airlink
@@ -19,18 +19,20 @@ define Device/ar670w
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
wrg-header wrgn16a_airlink_ar670w
+ SUPPORTED_DEVICES += ar670w
endef
-TARGET_DEVICES += ar670w
+TARGET_DEVICES += airlink101_ar670w
-define Device/ar725w
+define Device/airlink101_ar725w
DTS := AR725W
DEVICE_VENDOR := Airlink
DEVICE_MODEL := AR725W
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size 3328k | \
gemtek-header ar725w
+ SUPPORTED_DEVICES += ar725w
endef
-TARGET_DEVICES += ar725w
+TARGET_DEVICES += airlink101_ar725w
define Device/dlink_dap-1522-a1
DTS := DAP-1522-A1
@@ -50,7 +52,7 @@ define Device/dlink_dap-1522-a1
endef
TARGET_DEVICES += dlink_dap-1522-a1
-define Device/f5d8235-v1
+define Device/belkin_f5d8235-v1
DTS := F5D8235_V1
IMAGE_SIZE := 7744k
DEVICE_VENDOR := Belkin
@@ -58,44 +60,49 @@ define Device/f5d8235-v1
DEVICE_VARIANT := V1
DEVICE_PACKAGES := kmod-switch-rtl8366s kmod-usb-core kmod-usb-ohci \
kmod-usb-ohci-pci kmod-usb2 kmod-usb2-pci kmod-usb-ledtrig-usbport
+ SUPPORTED_DEVICES += f5d8235-v1
endef
-TARGET_DEVICES += f5d8235-v1
+TARGET_DEVICES += belkin_f5d8235-v1
-define Device/rt-n15
+define Device/asus_rt-n15
DTS := RT-N15
BLOCKSIZE := 64k
IMAGE_SIZE := $(ralink_default_fw_size_4M)
DEVICE_VENDOR := Asus
DEVICE_MODEL := RT-N15
DEVICE_PACKAGES := kmod-switch-rtl8366s
+ SUPPORTED_DEVICES += rt-n15
endef
-TARGET_DEVICES += rt-n15
+TARGET_DEVICES += asus_rt-n15
-define Device/v11st-fe
+define Device/ralink_v11st-fe
DTS := V11STFE
BLOCKSIZE := 64k
IMAGE_SIZE := $(ralink_default_fw_size_4M)
DEVICE_VENDOR := Ralink
DEVICE_MODEL := V11ST-FE
+ SUPPORTED_DEVICES += v11st-fe
endef
-TARGET_DEVICES += v11st-fe
+TARGET_DEVICES += ralink_v11st-fe
-define Device/wli-tx4-ag300n
+define Device/buffalo_wli-tx4-ag300n
DTS := WLI-TX4-AG300N
BLOCKSIZE := 64k
IMAGE_SIZE := $(ralink_default_fw_size_4M)
DEVICE_VENDOR := Buffalo
DEVICE_MODEL := WLI-TX4-AG300N
DEVICE_PACKAGES := kmod-switch-ip17xx
+ SUPPORTED_DEVICES += wli-tx4-ag300n
endef
-TARGET_DEVICES += wli-tx4-ag300n
+TARGET_DEVICES += buffalo_wli-tx4-ag300n
-define Device/wzr-agl300nh
+define Device/buffalo_wzr-agl300nh
DTS := WZR-AGL300NH
BLOCKSIZE := 64k
IMAGE_SIZE := $(ralink_default_fw_size_4M)
DEVICE_VENDOR := Buffalo
DEVICE_MODEL := WZR-AGL300NH
DEVICE_PACKAGES := kmod-switch-rtl8366s
+ SUPPORTED_DEVICES += wzr-agl300nh
endef
-TARGET_DEVICES += wzr-agl300nh
+TARGET_DEVICES += buffalo_wzr-agl300nh
diff --git a/target/linux/ramips/image/rt3883.mk b/target/linux/ramips/image/rt3883.mk
index 4150f96cf0..9e1d928603 100644
--- a/target/linux/ramips/image/rt3883.mk
+++ b/target/linux/ramips/image/rt3883.mk
@@ -5,7 +5,7 @@ define Build/mkrtn56uimg
$(STAGING_DIR_HOST)/bin/mkrtn56uimg $(1) $@
endef
-define Device/br-6475nd
+define Device/edimax_br-6475nd
DTS := BR-6475ND
BLOCKSIZE := 64k
IMAGE_SIZE := 7744k
@@ -15,10 +15,11 @@ define Device/br-6475nd
DEVICE_VENDOR := Edimax
DEVICE_MODEL := BR-6475nD
DEVICE_PACKAGES := swconfig
+ SUPPORTED_DEVICES += br-6475nd
endef
-TARGET_DEVICES += br-6475nd
+TARGET_DEVICES += edimax_br-6475nd
-define Device/cy-swr1100
+define Device/samsung_cy-swr1100
$(Device/seama)
DTS := CY-SWR1100
BLOCKSIZE := 64k
@@ -27,11 +28,12 @@ define Device/cy-swr1100
DEVICE_VENDOR := Samsung
DEVICE_MODEL := CY-SWR1100
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+ SUPPORTED_DEVICES += cy-swr1100
endef
-TARGET_DEVICES += cy-swr1100
+TARGET_DEVICES += samsung_cy-swr1100
-define Device/dir-645
+define Device/dlink_dir-645
$(Device/seama)
DTS := DIR-645
BLOCKSIZE := 4k
@@ -40,8 +42,9 @@ define Device/dir-645
DEVICE_VENDOR := D-Link
DEVICE_MODEL := DIR-645
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+ SUPPORTED_DEVICES += dir-645
endef
-TARGET_DEVICES += dir-645
+TARGET_DEVICES += dlink_dir-645
define Device/belkin_f9k1109v1
@@ -58,29 +61,31 @@ define Device/belkin_f9k1109v1
endef
TARGET_DEVICES += belkin_f9k1109v1
-define Device/hpm
+define Device/omnima_hpm
DTS := HPM
BLOCKSIZE := 64k
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Omnima
DEVICE_MODEL := HPM
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2
+ SUPPORTED_DEVICES += hpm
endef
-TARGET_DEVICES += hpm
+TARGET_DEVICES += omnima_hpm
-define Device/rt-n56u
+define Device/asus_rt-n56u
DTS := RT-N56U
BLOCKSIZE := 64k
IMAGE/sysupgrade.bin += | mkrtn56uimg -s
DEVICE_VENDOR := Asus
DEVICE_MODEL := RT-N56U
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+ SUPPORTED_DEVICES += rt-n56u
endef
-TARGET_DEVICES += rt-n56u
+TARGET_DEVICES += asus_rt-n56u
-define Device/tew-691gr
+define Device/trendnet_tew-691gr
DTS := TEW-691GR
BLOCKSIZE := 64k
IMAGES += factory.bin
@@ -89,11 +94,12 @@ define Device/tew-691gr
DEVICE_VENDOR := TRENDnet
DEVICE_MODEL := TEW-691GR
DEVICE_PACKAGES := swconfig
+ SUPPORTED_DEVICES += tew-691gr
endef
-TARGET_DEVICES += tew-691gr
+TARGET_DEVICES += trendnet_tew-691gr
-define Device/tew-692gr
+define Device/trendnet_tew-692gr
DTS := TEW-692GR
BLOCKSIZE := 64k
IMAGES += factory.bin
@@ -102,11 +108,12 @@ define Device/tew-692gr
DEVICE_VENDOR := TRENDnet
DEVICE_MODEL := TEW-692GR
DEVICE_PACKAGES := swconfig
+ SUPPORTED_DEVICES += tew-692gr
endef
-TARGET_DEVICES += tew-692gr
+TARGET_DEVICES += trendnet_tew-692gr
-define Device/wlr-6000
+define Device/sitecom_wlr-6000
DTS := WLR-6000
BLOCKSIZE := 4k
IMAGE_SIZE := 7244k
@@ -116,14 +123,16 @@ define Device/wlr-6000
DEVICE_VENDOR := Sitecom
DEVICE_MODEL := WLR-6000
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+ SUPPORTED_DEVICES += wlr-6000
endef
-TARGET_DEVICES += wlr-6000
+TARGET_DEVICES += sitecom_wlr-6000
-define Device/wmdr-143n
+define Device/loewe_wmdr-143n
DTS := WMDR-143N
BLOCKSIZE := 64k
DEVICE_VENDOR := Loewe
DEVICE_MODEL := WMDR-143N
+ SUPPORTED_DEVICES += wmdr-143n
endef
-TARGET_DEVICES += wmdr-143n
+TARGET_DEVICES += loewe_wmdr-143n