aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2019-06-25 23:32:20 +0800
committerPetr Štetiar <ynezz@true.cz>2019-06-26 07:41:54 +0200
commit3f68cffd276df5b164ea0c7ecafb8fa062aa7a41 (patch)
tree60c051af709d722a3600783dc3777a39c72c7249 /target/linux/ramips/image
parent110daa16e44bb53941a18396ab6a7d9fdd1fa362 (diff)
downloadupstream-3f68cffd276df5b164ea0c7ecafb8fa062aa7a41.tar.gz
upstream-3f68cffd276df5b164ea0c7ecafb8fa062aa7a41.tar.bz2
upstream-3f68cffd276df5b164ea0c7ecafb8fa062aa7a41.zip
ramips: add support for TOTOLINK A7000R
Specifications: - SoC: MT7621AT - RAM: 128MB - Flash: 16M SPI NOR - Ethernet: 5x GE ports - WiFi: 2.4G: MT7615N 5G: MT7615N Flash instruction: Upload generated sysupgrade firmware through factory web interface. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index c1e445f84c..dce24308b8 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -235,6 +235,15 @@ define Device/k2p
endef
TARGET_DEVICES += k2p
+define Device/totolink_a7000r
+ DTS := TOTOLINK-A7000R
+ IMAGE_SIZE := 16064k
+ UIMAGE_NAME := C8340R1C-9999
+ DEVICE_TITLE := TOTOLINK A7000R
+ DEVICE_PACKAGES := kmod-mt7615e wpad-basic
+endef
+TARGET_DEVICES += totolink_a7000r
+
define Device/xiaomi_mir3p
DTS := MIR3P
BLOCKSIZE := 128k