aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-04-23 16:56:05 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-04-23 16:56:05 +0000
commit3626444c6d4f6de3905a218061b16421870d580a (patch)
tree59eabddb813b014c7102017b92147fb96e14259f /target/linux/ramips/image
parent42c190ead8b626d4d74ff99b95fc08f361aaf5ee (diff)
downloadupstream-3626444c6d4f6de3905a218061b16421870d580a.tar.gz
upstream-3626444c6d4f6de3905a218061b16421870d580a.tar.bz2
upstream-3626444c6d4f6de3905a218061b16421870d580a.zip
ramips: rt305x: add support for the Asus WL-330N3G board
This patch adds support for the ASUS WL-330N3G Comparing to the WL-330N, It have 32MB ram, usb support and a bicolor led. The bi-color led is driven by 2 gpio. I don't know how to handle this, so I simply made 2 leds : one red, one blue. But the red light takes precedence over the blue one according to the chart below. r = led is red b = led is blue 0 = led is off xy= x->r for red, b for blue led, y->value of brightness in /sys/class/leds/x/brughtness initial state action led gpio state r0 b0 r0->r1 r r0 b0 r0 b0 b0->b1 b r0 b1 r1 b0 r1->r0 0 r0 b0 r1 b0 b0->b1 r r1 *b1* r1 b1 r1->r0 b r0 b1 r1 b1 b1->b0 r r1 b0 r0 b1 r0->r1 r r1 *b1* r0 b1 b1->b0 0 r0 r0 Signed-off-by: Frédéric Leroy <fredo@starox.org> SVN-Revision: 31450
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 1330fa318b..d3ddb728cd 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -395,6 +395,10 @@ define Image/Build/Profile/WL_330N
$(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,wl-330n,WL_330N,ttyS1,57600,spi)
endef
+define Image/Build/Profile/WL_330N3G
+ $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,wl-330n3g,WL_330N3G,ttyS1,57600,spi)
+endef
+
define Image/Build/Profile/WL341V3
$(call Image/Build/Template/$(fs_squash)/$(1),WL341V3,wl341v3,WL341V3)
endef
@@ -441,6 +445,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/WCR150GN,$(1))
$(call Image/Build/Profile/WHRG300N,$(1))
$(call Image/Build/Profile/WL_330N,$(1))
+ $(call Image/Build/Profile/WL_330N3G,$(1))
$(call Image/Build/Profile/WL341V3,$(1))
$(call Image/Build/Profile/WL351,$(1))
$(call Image/Build/Profile/WR5123GN,$(1))