aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2019-07-21 03:34:59 +0900
committerChuanhong Guo <gch981213@gmail.com>2019-08-17 23:52:34 +0800
commit2678ba909329aa8ffcf213c4b63bb1b001dd1a8c (patch)
treecdda148ae2361f1258a77b0e29f64638bae9594d /target/linux/ramips/image
parent68588e15184fe4b1fa99ccf969ee314cf55bc02e (diff)
downloadupstream-2678ba909329aa8ffcf213c4b63bb1b001dd1a8c.tar.gz
upstream-2678ba909329aa8ffcf213c4b63bb1b001dd1a8c.tar.bz2
upstream-2678ba909329aa8ffcf213c4b63bb1b001dd1a8c.zip
ramips: add support for ipTIME A604M
ipTIME A604M is a 2.4/5GHz band AC1200 router, based on MediaTek MT7628AN. Specifications: - SoC: MT7628AN - RAM: DDR2 64MB - Flash: SPI NOR 8MB - WiFi: - 2.4GHz: SoC internal - 5GHz: MT7612EN - Ethernet: 5x 10/100Mbps - Switch: SoC internal - UART: - J1: 3.3V, TX, RX, GND (3.3V is the square pad) / 57600 8N1 Installation via web interface: 1. Flash **initramfs** image through the stock web interface. 2. Boot into OpenWrt and perform sysupgrade with sysupgrade image. Revert to stock firmware: 1. Perform sysupgrade with stock image. Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt76x8.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index d560a2aab0..102d3d00fb 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -120,6 +120,16 @@ define Device/hiwifi_hc5861b
endef
TARGET_DEVICES += hiwifi_hc5861b
+define Device/iptime_a604m
+ MTK_SOC := mt7628an
+ IMAGE_SIZE := 7936k
+ UIMAGE_NAME := a604m
+ DEVICE_VENDOR := ipTIME
+ DEVICE_MODEL := A604M
+ DEVICE_PACKAGES := kmod-mt76x2
+endef
+TARGET_DEVICES += iptime_a604m
+
define Device/mediatek_linkit-smart-7688
MTK_SOC := mt7628an
IMAGE_SIZE := 32448k