aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-02-04 11:02:36 +0100
committerMathias Kresin <dev@kresin.me>2017-02-04 13:46:48 +0100
commit1ba7fa652cffffabb77f23a4d745633050c5c175 (patch)
tree2967cd8a0a5513b17acfd4ccef2a77b1012879cf /target/linux/ramips/image
parent785f2a70daa08d6965e94d96c60b1b041cc5cf7e (diff)
downloadupstream-1ba7fa652cffffabb77f23a4d745633050c5c175.tar.gz
upstream-1ba7fa652cffffabb77f23a4d745633050c5c175.tar.bz2
upstream-1ba7fa652cffffabb77f23a4d745633050c5c175.zip
ramips: fix Airlink AR725W factory image build
The factory image can't be bigger than 3328 KByte. If the image is bigger than that, the gemtek-header tool throws an error and breaks the build. Make sure the output file to which the gemtek header should be added exists and wasn't removed during the check-size step because of it size. This will prevent hard errors in case the factory image is to big similar to what is done for sysupgrade images. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/rt288x.mk7
1 files changed, 5 insertions, 2 deletions
diff --git a/target/linux/ramips/image/rt288x.mk b/target/linux/ramips/image/rt288x.mk
index fbe50a2824..33830a6e78 100644
--- a/target/linux/ramips/image/rt288x.mk
+++ b/target/linux/ramips/image/rt288x.mk
@@ -3,7 +3,10 @@
#
define Build/gemtek-header
- mkheader_gemtek $@ $@.new $(1) && mv $@.new $@
+ if [ -f $@ ]; then \
+ mkheader_gemtek $@ $@.new $(1) && \
+ mv $@.new $@; \
+ fi
endef
define Device/ar670w
@@ -22,7 +25,7 @@ define Device/ar725w
DTS := AR725W
DEVICE_TITLE := Gemtek AR725W
IMAGES += factory.bin
- IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
+ IMAGE/factory.bin := $$(sysupgrade_bin) | check-size 3328k | \
gemtek-header ar725w
endef
TARGET_DEVICES += ar725w