aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorAdemar Arvati Filho <arvati@hotmail.com>2018-07-04 01:29:36 +0000
committerMathias Kresin <dev@kresin.me>2018-07-07 21:07:40 +0200
commit16d6a63f857a4e9eeb1f173e964264d8a06e65eb (patch)
tree7ea24d1f7348bd396049caa6043826d2c60a36dd /target/linux/ramips/image
parenta28d686fb679e473cdae1366e7591a97d57ea8af (diff)
downloadupstream-16d6a63f857a4e9eeb1f173e964264d8a06e65eb.tar.gz
upstream-16d6a63f857a4e9eeb1f173e964264d8a06e65eb.tar.bz2
upstream-16d6a63f857a4e9eeb1f173e964264d8a06e65eb.zip
ramips: add support for Blueendless Kimax U35WF
Blueendless Kimax U35WF is a 3,5" HDD Enclosure with Wi-Fi and Ethernet Patch rewritten from: https://forum.openwrt.org/viewtopic.php?id=66908 Based on: https://github.com/lede-project/source/pull/965 Specification: - SoC: MediaTek MT7620N - CPU/Speed: 580 MHz - Flash-Chip: KH25L12835F Spi Flash - Flash size: 16 MiB - RAM: 64 MiB - LAN: 1x 100 Mbps Ethernet - WiFi SoC-integrated: 802.11bgn - 1x USB 2.0 - UART: for serial console Installation: 1. Download sysupgrade.bin 2. Open vendor web interface 3. Choose to upgrade firmware 3. After reboot connect via ethernet at 192.168.1.1 Signed-off-by: Ademar Arvati Filho <arvati@hotmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7620.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 736741a4ba..c968825754 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -280,6 +280,13 @@ define Device/hc5861
endef
TARGET_DEVICES += hc5861
+define Device/kimax_u35wf
+ DTS := U35WF
+ IMAGE_SIZE := 16064k
+ DEVICE_TITLE := Kimax U35WF
+endef
+TARGET_DEVICES += kimax_u35wf
+
define Device/kng_rc
DTS := kng_rc
IMAGE_SIZE := $(ralink_default_fw_size_16M)