aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2019-07-11 14:41:08 +0900
committerChuanhong Guo <gch981213@gmail.com>2019-09-25 14:44:36 +0800
commit12ab6ef5c377e9d4aa8f0758ca92056da7eea0bf (patch)
tree8b00dfdb3e70fc5240b5088c8a0677cc34087d7e /target/linux/ramips/image
parentc1394dabf6547dbc25e9563ef980aed9589479ab (diff)
downloadupstream-12ab6ef5c377e9d4aa8f0758ca92056da7eea0bf.tar.gz
upstream-12ab6ef5c377e9d4aa8f0758ca92056da7eea0bf.tar.bz2
upstream-12ab6ef5c377e9d4aa8f0758ca92056da7eea0bf.zip
ramips: add support for I-O DATA WNPR2600G
I-O DATA WNPR2600G is a 2.4/5 GHz band 11ac router, based on MediaTek MT7621A. Specification: - SoC : MediaTek MT7621A - RAM : DDR3 128 MiB - Flash : SPI-NOR 16 MiB - WLAN : 2.4/5 GHz 4T4R - 2.4 GHz : MediaTek MT7615 - 5 GHz : MediaTek MT7615 - Ethernet : 10/100/1000 Mbps - Switch : MT7530 (SoC) - LED/keys : 4x/3x (2x buttons, 1x slide-switch) - UART : through-hole on PCB - J1: Vcc, RX, GND, TX from SoC side - 57600n8 Flash instruction using factory image: 1. Boot WNPR2600G normaly 2. Access to "http://192.168.0.1/" and open firmware update page ("ファームウェア") 3. Select the OpenWrt factory image and click update ("更新") button to perform firmware update 4. Wait ~150 seconds to complete flashing Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 4cf9cf7ff2..816652ddaa 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -322,6 +322,19 @@ define Device/iodata_wn-gx300gr
endef
TARGET_DEVICES += iodata_wn-gx300gr
+define Device/iodata_wnpr2600g
+ MTK_SOC := mt7621
+ DEVICE_VENDOR := I-O DATA
+ DEVICE_MODEL := WNPR2600G
+ IMAGE_SIZE := 13952k
+ IMAGES += factory.bin
+ IMAGE/factory.bin := \
+ $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
+ elx-header 0104003a 8844A2D168B45A2D
+ DEVICE_PACKAGES := kmod-mt7615e wpad-basic
+endef
+TARGET_DEVICES += iodata_wnpr2600g
+
define Device/lenovo_newifi-d1
MTK_SOC := mt7621
IMAGE_SIZE := 32448k