aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2019-05-16 15:09:07 +0800
committerPetr Štetiar <ynezz@true.cz>2019-06-05 10:26:33 +0200
commit0ab9f283f75ad8314ad4be7c70d1397e9dbbfe15 (patch)
tree6af3612ae6508ac96d98823f6e3bdd07dc13344a /target/linux/ramips/image
parent64493d42b41253aafe1538e325e0692db4201046 (diff)
downloadupstream-0ab9f283f75ad8314ad4be7c70d1397e9dbbfe15.tar.gz
upstream-0ab9f283f75ad8314ad4be7c70d1397e9dbbfe15.tar.bz2
upstream-0ab9f283f75ad8314ad4be7c70d1397e9dbbfe15.zip
ramips: add support for TOTOLINK LR1200
Specifications: - SoC: MT7628DAN (MT7628AN with 64MB built-in RAM) - Flash: 8M SPI NOR - Ethernet: 5x 10/100Mbps - WiFi: 2.4G: MT7628 built-in 5G: MT7612E - 1x miniPCIe slot for LTE modem (only USB pins connected) - 1x SIM slot Flash instruction: U-boot has a builtin web recovery page: 1. Hold the reset button while powering it up 2. Connect to the ethernet and set an IP in 192.168.1.0/24 range 3. Open your browser and upload firmware through http://192.168.1.1 Note about the LTE modem: If your router comes with an EC25 module and it doesn't show up as a QMI device, you should do the following to switch it to QMI mode: 1. Install kmod-usb-serial-option and a terminal software (e.g. minicom or screen). All 4 serial ports of the modem should be available now. 2. Open /dev/ttyUSB3 with the terminal software and type this AT command: AT+QCFG="usbnet",0 3. Power-cycle the router. You should now get a QMI device recognized. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt76x8.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 4e6a5d1ca9..2280a1a618 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -183,6 +183,14 @@ define Device/skylab_skw92a
endef
TARGET_DEVICES += skylab_skw92a
+define Device/totolink_lr1200
+ DTS := TOTOLINK-LR1200
+ IMAGE_SIZE := 7872k
+ DEVICE_TITLE := TOTOLINK LR1200
+ DEVICE_PACKAGES := kmod-mt76x2 kmod-usb2 uqmi
+endef
+TARGET_DEVICES += totolink_lr1200
+
define Device/tplink_tl-wa801nd-v5
$(Device/tplink)
DTS := TL-WA801NDV5