aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorAlex Maclean <monkeh@monkeh.net>2017-07-23 20:06:44 +0100
committerMathias Kresin <dev@kresin.me>2017-07-25 21:02:53 +0200
commitf683385e73f09c13fd08c3d352f3f1739c1944c4 (patch)
treed5a10f6a8d7fbfa6a6639b9a202a88c6cc7616eb /target/linux/ramips/image
parent1c7144f078c98dbf0e6c70c534b98fe6186f19d6 (diff)
downloadupstream-f683385e73f09c13fd08c3d352f3f1739c1944c4.tar.gz
upstream-f683385e73f09c13fd08c3d352f3f1739c1944c4.tar.bz2
upstream-f683385e73f09c13fd08c3d352f3f1739c1944c4.zip
ramips: add support for TP-Link RE350
The TP-Link RE350 is a wall-wart AC1200 range extender/access point with a single gigabit ethernet port and two non-detachable antennas, based on the MT7621A SoC with MT7603E and MT7612E radios. Firmware wise it is very similar to the QCA based RE450. SoC: MediaTek MT7621A (880MHz) Flash: 8MiB (Winbond W25Q64) RAM: 64MiB (DDR2) Ethernet: 1x 1Gbit Wireless: 2T2R 2.4Ghz (MT7603E) and 5GHz (MT7612E) LEDs: Power, 2.4G, 5G (blue), WPS (red and blue), ethernet link/act (green) Buttons: On/off, LED, reset, WPS Serial header at J1, 57600 8n1: Pin 1 TX Pin 2 RX Pin 3 GND Pin 4 3.3V Factory image can be uploaded directly through the stock UI. Signed-off-by: Alex Maclean <monkeh@monkeh.net>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 103534e060..bf0e292286 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -2,6 +2,8 @@
# MT7621 Profiles
#
+DEVICE_VARS += TPLINK_BOARD_ID TPLINK_HEADER_VERSION TPLINK_HWID TPLINK_HWREV
+
define Build/ubnt-erx-factory-image
if [ -e $(KDIR)/tmp/$(KERNEL_INITRAMFS_IMAGE) -a "$$(stat -c%s $@)" -lt "$(KERNEL_SIZE)" ]; then \
echo '21001:6' > $(1).compat; \
@@ -148,6 +150,22 @@ define Device/rb750gr3
endef
TARGET_DEVICES += rb750gr3
+define Device/re350-v1
+ DTS := RE350
+ DEVICE_TITLE := TP-LINK RE350 v1
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 wpad-mini
+ TPLINK_BOARD_ID := RE350-V1
+ TPLINK_HWID := 0x0
+ TPLINK_HWREV := 0
+ TPLINK_HEADER_VERSION := 1
+ IMAGE_SIZE := 6016k
+ KERNEL := $(KERNEL_DTB) | tplink-v1-header -e
+ IMAGES := sysupgrade.bin factory.bin
+ IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade | append-metadata | check-size $$$$(IMAGE_SIZE)
+ IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
+endef
+TARGET_DEVICES += re350-v1
+
define Device/re6500
DTS := RE6500
DEVICE_TITLE := Linksys RE6500