aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorKip Porterfield <kip.porterfield@gmail.com>2019-02-03 13:54:18 -0500
committerChristian Lamparter <chunkeey@gmail.com>2019-03-02 13:04:45 +0100
commitf2c83532f92c5fa43165e1c5a3cd7f5cf4e9e3b3 (patch)
treecc3f4fc38a629e19a0939adde82b30c6cdf9d849 /target/linux/ramips/image
parent6c558bae648ea8bca8fc8fcbee760a0cdc9ca9c9 (diff)
downloadupstream-f2c83532f92c5fa43165e1c5a3cd7f5cf4e9e3b3.tar.gz
upstream-f2c83532f92c5fa43165e1c5a3cd7f5cf4e9e3b3.tar.bz2
upstream-f2c83532f92c5fa43165e1c5a3cd7f5cf4e9e3b3.zip
ramips: add support for Belkin F9K1109v1
Device specification: - SoC: Ralink RT3883 (MIPS 74Kc) 500Mhz - RAM: 64Mb - Flash: 8MB (SPI-NOR) - Ethernet: 10/100/1000 Mbps - WLAN Wireless 1: SoC-integrated : 2.4/5 GHz Wireless 2: 2.4 GHz RT3092L - LED: 2x USB, WAN, LAN - Key: WPS, reset - Serial: 4-pin header, (57600,8,N,1), 3.3V TTL, GND, RX, TX, V - J12 marking on board - USB ports: 2 x USB 2.0 Flashing instructions: Option 1 (from bootloader web) - Hold reset button on the back of router when plugging in power (for at-least 10 seconds after plugged in) - Connect to a Lan port - Set computer IP to 10.10.10.3 - Go to http://10.10.10.123 in a web browser - Click the Browse... Button and select the *squashfs.sysupgrade.bin file then click APPLY Option 2 (from the stock admin web) - Go to firmware upgrade - Upload the **factory** image *initramfs.bin first - Boot into openwrt - From Luci web in openwrt upload the *squashfs.sysupgrade.bin Signed-off-by: Kip Porterfield <kip.porterfield@gmail.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [added v1 to the compatible identifier, added pciid for the RT3092L, fixed pci unit-address, split out the F9K110X.dtsi to prepare for a possible F9K1103 patch]
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/rt3883.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ramips/image/rt3883.mk b/target/linux/ramips/image/rt3883.mk
index abee533d01..41b2c3dd5f 100644
--- a/target/linux/ramips/image/rt3883.mk
+++ b/target/linux/ramips/image/rt3883.mk
@@ -41,6 +41,18 @@ endef
TARGET_DEVICES += dir-645
+define Device/belkin_f9k1109v1
+ DTS := F9K1109V1
+ BLOCKSIZE := 64k
+ DEVICE_TITLE := Belkin F9K1109 Version 1.0
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+ IMAGE_SIZE := 7224k
+ KERNEL := kernel-bin | patch-dtb | lzma -d16 | uImage lzma
+ # Stock firmware checks for this uImage image name during upload.
+ UIMAGE_NAME := N750F9K1103VB
+endef
+TARGET_DEVICES += belkin_f9k1109v1
+
define Device/hpm
DTS := HPM
BLOCKSIZE := 64k