aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorNishant Sharma <nishant@unmukti.in>2018-10-24 19:53:20 +0530
committerMathias Kresin <dev@kresin.me>2018-11-28 01:11:38 +0100
commitdf3e0b580644bd8434a690802e3c5c18a6e38098 (patch)
tree7db6c20380d174742ea19c1c99341d3e44c34c32 /target/linux/ramips/image
parent509d02a3d185e5fb240496471455f8999f8bd767 (diff)
downloadupstream-df3e0b580644bd8434a690802e3c5c18a6e38098.tar.gz
upstream-df3e0b580644bd8434a690802e3c5c18a6e38098.tar.bz2
upstream-df3e0b580644bd8434a690802e3c5c18a6e38098.zip
ramips: add support for UniElec U7621-06-512M-64M variant
Add support for UniElec U7621-06 variant with 512MB RAM and 64MB flash. Additional specs are below: CPU: MT7621 (880Mhz) Bootloader: Ralink U-Boot Flash: 64MB - U-Boot identifies as Macronix MX66L51235F - kernel identifies as MX66L51235l (65536 Kbytes) RAM: 512MB Rest of the details as per commit 46ab81e405d2 ("ramips add support for UniElec U7621-06") Signed-off-by: Nishant Sharma <nishant@unmukti.in> [use generic board detection, add firmware partition compatible, extend firmware partition to use all of the remaining flash space, add a maximum image size matching the firmware partition size] Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index e6059e6977..47ff85f241 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -395,6 +395,14 @@ define Device/unielec_u7621-06-256m-16m
endef
TARGET_DEVICES += unielec_u7621-06-256m-16m
+define Device/unielec_u7621-06-512m-64m
+ DTS := U7621-06-512M-64M
+ IMAGE_SIZE := 65216k
+ DEVICE_TITLE := UniElec U7621-06 (512M RAM/64M flash)
+ DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-sdhci-mt7620 kmod-usb3
+endef
+TARGET_DEVICES += unielec_u7621-06-512m-64m
+
define Device/vr500
DTS := VR500
IMAGE_SIZE := 66453504