aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2019-05-09 18:04:06 +0200
committerChristian Lamparter <chunkeey@gmail.com>2019-05-11 16:37:11 +0200
commita4dc51988833a3fb29fee80d549819b4c06c277d (patch)
treebec3940a77c414f58c2956d9f4f145c96ff15006 /target/linux/ramips/image
parent0a11c87e4623d51d341e80fb01211ac736f3b3fa (diff)
downloadupstream-a4dc51988833a3fb29fee80d549819b4c06c277d.tar.gz
upstream-a4dc51988833a3fb29fee80d549819b4c06c277d.tar.bz2
upstream-a4dc51988833a3fb29fee80d549819b4c06c277d.zip
ramips: fix R6120 factory image
The factory firmware omits the JFFS2 end-marker while flashing via web-interface. Add a 64k padding after the marker fixes this problem. When the end-marker is not present, OpenWRT won't save the overlayfs after initial flash. Reported-by: Andreas Ziegler <dev@andreas-ziegler.de> Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt76x8.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 571ddf3d51..ba3354a8a6 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -135,7 +135,7 @@ define Device/netgear_r6120
IMAGES += factory.img
IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE)| append-rootfs | pad-rootfs
IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | check-size $$$$(IMAGE_SIZE)
- IMAGE/factory.img := pad-extra 576k | $$(IMAGE/default) | \
+ IMAGE/factory.img := pad-extra 576k | $$(IMAGE/default) | pad-to $$$$(BLOCKSIZE) | \
sercom-footer | pad-to 128 | zip R6120.bin | sercom-seal
endef
TARGET_DEVICES += netgear_r6120