aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorTobias Welz <tw@wiznet.eu>2019-01-12 00:37:43 +0100
committerPetr Štetiar <ynezz@true.cz>2019-03-29 07:33:59 +0000
commit7c4b85ee278576816b0f9d20e48fa696f8793fdf (patch)
tree4bfd2cbb03c6866948cb179f48f56d4c093805e3 /target/linux/ramips/image
parentb0395cfc5625328ad824c605bad89f1ae0781e3e (diff)
downloadupstream-7c4b85ee278576816b0f9d20e48fa696f8793fdf.tar.gz
upstream-7c4b85ee278576816b0f9d20e48fa696f8793fdf.tar.bz2
upstream-7c4b85ee278576816b0f9d20e48fa696f8793fdf.zip
ramips: add support for WIZnet WizFi630S board
The WIZnet WizFi630S board is in the miniPCIe form factor. SoC: Mediatek MT7688AN RAM: 128MB Flash: 32Mb WiFi: 2.4GHz Ethernet: 3x 100Mbit USB: 1 (USB 2.0) serial ports: 2 (1x full, 1xlite) Flash and recovery instructions: Use the factory installed u-boot boot loader. It is available on UART2 (115200,8,n,1). Then get the sysupgrade image from a tftp server. Signed-off-by: Tobias Welz <tw@wiznet.eu> [whitespace and device name in makefile fixes] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt76x8.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 414798d08c..cb8f181955 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -408,6 +408,13 @@ define Device/widora_neo-32m
endef
TARGET_DEVICES += widora_neo-32m
+define Device/wiznet_wizfi630s
+ DTS := WIZFI630S
+ IMAGE_SIZE := $(ralink_default_fw_size_32M)
+ DEVICE_TITLE := WIZnet WizFi630S
+endef
+TARGET_DEVICES += wiznet_wizfi630s
+
define Device/wrtnode2p
DTS := WRTNODE2P
IMAGE_SIZE := $(ralink_default_fw_size_16M)