aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2019-03-21 15:55:09 +0100
committerPetr Štetiar <ynezz@true.cz>2019-03-29 07:34:00 +0000
commit3f019bf96cdf52668750f67cb139fa1b5c538f0b (patch)
treebac3ef1accb91a010a6adff664df8ace4a888b38 /target/linux/ramips/image
parent58becdb30d1048903ad704a227a52bdf695a0087 (diff)
downloadupstream-3f019bf96cdf52668750f67cb139fa1b5c538f0b.tar.gz
upstream-3f019bf96cdf52668750f67cb139fa1b5c538f0b.tar.bz2
upstream-3f019bf96cdf52668750f67cb139fa1b5c538f0b.zip
ramips: add Netgear EX6150
SoC: MediaTek MT7621 RAM: 64M (Winbond W9751G6KB-25) FLASH: 16MB (Macronix MX25L12835F) WiFi: MediaTek MT7662E bgn 2SS WiFi: MediaTek MT7662E nac 2SS BTN: ON/OFF - Reset - WPS - AP/Extender toggle LED: - Arrow Right (blue) - Arrow Left (blue) - WiFi 1 (red/green) - WiFi 2 (red/green) - Power (green/amber) - WPS (Green) UART: UART is present as Pads on the backside of the PCB. They are located on the other side of the Ethernet port. 3.3V - GND - TX - RX / 57600-8N1 3.3V is the nearest one to the antenna connectors Installation ------------ Update the factory image via the Netgear web-interfaces (by default: 192.168.1.250/24). You can also use the factory image with the nmrpflash tool. For more information see https://github.com/jclehner/nmrpflash Signed-off-by: David Bauer <mail@david-bauer.net> [merge conflict in 02_network, flash@0 node rename, wlan DTS triggers] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 1f514a6d04..b15dfacaf6 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -324,6 +324,17 @@ define Device/r6220
endef
TARGET_DEVICES += r6220
+define Device/netgear_ex6150
+ DTS := EX6150
+ DEVICE_TITLE := Netgear EX6150
+ DEVICE_PACKAGES := kmod-mt76x2 wpad-basic
+ NETGEAR_BOARD_ID := U12H318T00_NETGEAR
+ IMAGE_SIZE := 14848k
+ IMAGES += factory.chk
+ IMAGE/factory.chk := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | netgear-chk
+endef
+TARGET_DEVICES += netgear_ex6150
+
define Device/netgear_r6350
DTS := R6350
BLOCKSIZE := 128k