aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorJan Hoffmann <jan@3e8.eu>2019-05-15 19:11:01 +0000
committerChristian Lamparter <chunkeey@gmail.com>2019-05-18 16:44:41 +0200
commit2fdd02cc7c3516c2cce2ace2c7b539e0821ecbe8 (patch)
treef2888a10b7fcf13e16805b437f5f67b4d8ac4262 /target/linux/ramips/image
parentd4b89b7170ab82530cfaf21e5f00bee7088432e2 (diff)
downloadupstream-2fdd02cc7c3516c2cce2ace2c7b539e0821ecbe8.tar.gz
upstream-2fdd02cc7c3516c2cce2ace2c7b539e0821ecbe8.tar.bz2
upstream-2fdd02cc7c3516c2cce2ace2c7b539e0821ecbe8.zip
ramips: add factory image for WNDR3700v5
This uses the existing rules for Sercomm factory images and moves them to the ramips image Makefile, so they can be used in all subtargets. The new factory image for WNDR3700v5 can be flashed using nmrpflash. Signed-off-by: Jan Hoffmann <jan@3e8.eu>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile14
-rw-r--r--target/linux/ramips/image/mt7621.mk11
-rw-r--r--target/linux/ramips/image/mt76x8.mk16
3 files changed, 24 insertions, 17 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 6eef596caf..145dbf4ec5 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -10,6 +10,7 @@ include $(INCLUDE_DIR)/image.mk
DEVICE_VARS += DTS IMAGE_SIZE NETGEAR_BOARD_ID NETGEAR_HW_ID
DEVICE_VARS += BUFFALO_TAG_PLATFORM BUFFALO_TAG_VERSION BUFFALO_TAG_MINOR
DEVICE_VARS += SEAMA_SIGNATURE SEAMA_MTDBLOCK
+DEVICE_VARS += SERCOMM_HWID SERCOMM_HWVER SERCOMM_SWVER
loadaddr-y := 0x80000000
loadaddr-$(CONFIG_TARGET_ramips_rt288x) := 0x88000000
@@ -132,6 +133,19 @@ define Build/zyimage
$(STAGING_DIR_HOST)/bin/zyimage $(1) $@
endef
+define Build/sercom-seal
+ $(STAGING_DIR_HOST)/bin/mksercommfw \
+ -i $@ \
+ -b $(SERCOMM_HWID) \
+ -r $(SERCOMM_HWVER) \
+ -v $(SERCOMM_SWVER) \
+ $(1)
+endef
+
+define Build/sercom-footer
+ $(call Build/sercom-seal,-f)
+endef
+
ralink_default_fw_size_4M=3866624
ralink_default_fw_size_8M=8060928
ralink_default_fw_size_16M=16121856
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 9e42404f64..671e7f378a 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -531,7 +531,16 @@ TARGET_DEVICES += mqmaker_witi-512m
define Device/wndr3700v5
DTS := WNDR3700V5
- IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ BLOCKSIZE := 64k
+ IMAGE_SIZE := 15232k
+ SERCOMM_HWID := AYB
+ SERCOMM_HWVER := A001
+ SERCOMM_SWVER := 0x1054
+ IMAGES += factory.img
+ IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs
+ IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | check-size $$$$(IMAGE_SIZE)
+ IMAGE/factory.img := pad-extra 320k | $$(IMAGE/default) | pad-to $$$$(BLOCKSIZE) | \
+ sercom-footer | pad-to 128 | zip WNDR3700v5.bin | sercom-seal
DEVICE_TITLE := Netgear WNDR3700v5
DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 wpad-basic
endef
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 0fd72a4117..22d79bad39 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -2,22 +2,6 @@
# MT76x8 Profiles
#
-DEVICE_VARS += SERCOMM_HWID SERCOMM_HWVER SERCOMM_SWVER
-
-define Build/sercom-seal
- $(STAGING_DIR_HOST)/bin/mksercommfw \
- -i $@ \
- -b $(SERCOMM_HWID) \
- -r $(SERCOMM_HWVER) \
- -v $(SERCOMM_SWVER) \
- $(1)
-endef
-
-define Build/sercom-footer
- $(call Build/sercom-seal,-f)
-endef
-
-
define Device/tplink
TPLINK_FLASHLAYOUT :=
TPLINK_HWID :=