aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2018-06-16 00:27:51 +0900
committerMathias Kresin <dev@kresin.me>2018-06-19 22:46:04 +0200
commitda318f3522344ae3344b94c85dae41eeb53b04cc (patch)
tree37fdb1d50aa02411f7eeb920e9ecf9fbe81c0d94 /target/linux/ramips/image
parentafe0320ffc212b405e068281d636626df754261e (diff)
downloadupstream-da318f3522344ae3344b94c85dae41eeb53b04cc.tar.gz
upstream-da318f3522344ae3344b94c85dae41eeb53b04cc.tar.bz2
upstream-da318f3522344ae3344b94c85dae41eeb53b04cc.zip
ramips: add support for ELECOM WRC-1167GHBK2-S
ELECOM WRC-1167GHBK2-S is a 2.4/5 GHz band 11ac router, based on MediaTek MT7621A. Specification: - MT7621A (2-Cores, 4-Threads) - 128 MB of RAM (DDR3) - 16 MB of Flash (SPI) - 2T2R 2.4/5 GHz - MediaTek MT7615D - 5x 10/100/1000 Mbps Ethernet - 6x LEDs, 2x keys - UART header on PCB - Vcc, GND, TX, RX from ethernet port side - baudrate: 57600 bps Flash instruction using factory image: 1. Rename the factory image to "wrc-1167ghbk2-s_v0.00.bin" 2. Connect the computer to the LAN port of WRC-1167GHBK2-S 3. Connect power cable to WRC-1167GHBK2-S and turn on it 4. Access to "http://192.168.2.1/details.html" and open firmware update page ("手動更新(アップデート)") 5. Select the factory image and click apply ("適用") button 6. Wait ~150 seconds to complete flashing Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index f8fb28196b..f6f8ea065b 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -4,6 +4,18 @@
DEVICE_VARS += TPLINK_BOARD_ID TPLINK_HEADER_VERSION TPLINK_HWID TPLINK_HWREV
+define Build/elecom-wrc-factory
+ $(eval product=$(word 1,$(1)))
+ $(eval version=$(word 2,$(1)))
+ $(STAGING_DIR_HOST)/bin/mkhash md5 $@ >> $@
+ ( \
+ echo -n "ELECOM $(product) v$(version)" | \
+ dd bs=32 count=1 conv=sync; \
+ dd if=$@; \
+ ) > $@.new
+ mv $@.new $@
+endef
+
define Build/ubnt-erx-factory-image
if [ -e $(KDIR)/tmp/$(KERNEL_INITRAMFS_IMAGE) -a "$$(stat -c%s $@)" -lt "$(KERNEL_SIZE)" ]; then \
echo '21001:6' > $(1).compat; \
@@ -65,6 +77,16 @@ define Device/mediatek_ap-mt7621a-v60
endef
TARGET_DEVICES += mediatek_ap-mt7621a-v60
+define Device/elecom_wrc-1167ghbk2-s
+ DTS := WRC-1167GHBK2-S
+ IMAGE_SIZE := 15488k
+ DEVICE_TITLE := ELECOM WRC-1167GHBK2-S
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) |\
+ elecom-wrc-factory WRC-1167GHBK2-S 0.00
+endef
+TARGET_DEVICES += elecom_wrc-1167ghbk2-s
+
define Device/ew1200
DTS := EW1200
IMAGE_SIZE := $(ralink_default_fw_size_16M)