aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-01-17 14:06:13 +0000
committerJohn Crispin <john@openwrt.org>2015-01-17 14:06:13 +0000
commit88df2bd2ff5aa7b31ce9aaeda25c60e8a9b980b2 (patch)
treea12ec319f40eaf27b5bbf6000bc60429e781f051 /target/linux/ramips/image
parent744298b8a0dc363a802634b5ac5d08e861e65d12 (diff)
downloadupstream-88df2bd2ff5aa7b31ce9aaeda25c60e8a9b980b2.tar.gz
upstream-88df2bd2ff5aa7b31ce9aaeda25c60e8a9b980b2.tar.bz2
upstream-88df2bd2ff5aa7b31ce9aaeda25c60e8a9b980b2.zip
ramips: add support for Intenso Memory 2 Move USB 3.0
This adds support for a rt5350-based "portable nas" solution from Intenso. The board comes with 32M RAM and 8M Flash, the built-in HDD is connected/accessible via a usb3.0<->sata bridge VLI VL701. The device has 1 Ethernet port (100M/10M), 1 micro b usb 3.0 socket (for charging the battery, or accessing the hdd directly). Wireless connectivity is provided by the rt5350 SoC [i.e.: 802.11n 1x1 2.4 GHz with a pcb antenna.] Serial, leds, wifi, ethernet and usb are tested and as far as I can tell: they are working fine (tm). Signed-off-by: Christian Lamparter <chunkeey@googlemail.com> SVN-Revision: 44001
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 21c8a8ddc9..5e4cea35ac 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -546,6 +546,8 @@ Image/Build/Profile/NCS601W=$(call BuildFirmware/Default8M/$(1),$(1),ncs601W,NCS
nw718_mtd_size=3801088
Image/Build/Profile/NW718=$(call BuildFirmware/CustomFlashFactory/$(1),$(1),nw718m,NW718,$(nw718_mtd_size),ARA1B4NCRNW718;1,factory)
+Image/Build/Profile/M2M=$(call BuildFirmware/Default8M/$(1),$(1),m2m,M2M,Linux Kernel Image)
+
Image/Build/Profile/OMNI-EMB=$(call BuildFirmware/Default8M/$(1),$(1),omni-emb,OMNI-EMB)
Image/Build/Profile/OMNI-PLUG=$(call BuildFirmware/Default8M/$(1),$(1),omni-plug,OMNI-PLUG)
@@ -694,6 +696,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/HT-TM02,$(1))
$(call Image/Build/Profile/HW550-3G,$(1))
$(call Image/Build/Profile/IP2202,$(1))
+ $(call Image/Build/Profile/M2M,$(1))
$(call Image/Build/Profile/M3,$(1))
$(call Image/Build/Profile/M4,$(1))
$(call Image/Build/Profile/MOFI3500-3GN,$(1))