aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-03-04 08:33:17 +0000
committerJohn Crispin <john@openwrt.org>2016-03-04 08:33:17 +0000
commit77da9390da4a78fa9a9aafb0a021b7b2fd61e29b (patch)
tree35fa24643a51edeb21be565d960cd74a77d34b47 /target/linux/ramips/image
parent3b39bf7262473069491df321561fc743b8e88e39 (diff)
downloadupstream-77da9390da4a78fa9a9aafb0a021b7b2fd61e29b.tar.gz
upstream-77da9390da4a78fa9a9aafb0a021b7b2fd61e29b.tar.bz2
upstream-77da9390da4a78fa9a9aafb0a021b7b2fd61e29b.zip
ramips: mt7621: fix WF-2881 for ubi split
This patch fix firmware split for WF-2881 which was previously manually partitioned. Signed-off-by: YounJae Rho <luxflow@live.com> SVN-Revision: 48908
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index eb50cddeaf..f5e8e58ef9 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -1115,9 +1115,10 @@ define Device/wf-2881
DTS := WF-2881
BLOCKSIZE := 128KiB
PAGESIZE := 2048
- KERNEL_SIZE := 2097152
FILESYSTEMS := squashfs
- IMAGE/sysupgrade.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | check-size $$$$(IMAGE_SIZE)
+ IMAGE_SIZE := 132382720
+ KERNEL := $(KERNEL_DTB) | pad-offset 131072 64 | uImage lzma
+ IMAGE/sysupgrade.bin := append-kernel | append-ubi | check-size $$$$(IMAGE_SIZE)
endef
define Device/ubnt-erx