aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorHenryk Heisig <hyniu@o2.pl>2017-12-15 15:57:49 +0100
committerMathias Kresin <dev@kresin.me>2017-12-23 15:35:52 +0100
commit39e9bfb18199b046bd3b613002112e4e6dd53658 (patch)
treece67800be1fe11212ebe26592907817008b37aa0 /target/linux/ramips/image
parent8ca650b8ce22fe2175cf15cfdd0e25206dd77481 (diff)
downloadupstream-39e9bfb18199b046bd3b613002112e4e6dd53658.tar.gz
upstream-39e9bfb18199b046bd3b613002112e4e6dd53658.tar.bz2
upstream-39e9bfb18199b046bd3b613002112e4e6dd53658.zip
ramips: add support for TP-Link TL-MR3420 v5
TP-Link TL-MR3420 v5 are simple N300 router with 5-port FE switch and non-detachable antennas. Its very similar to TP-Link TL-WR841N V13. Specification: - MT7628N/N (580 MHz) - 64 MB of RAM (DDR2) - 8 MB of FLASH - 2T2R 2.4 GHz - 5x 10/100 Mbps Ethernet - 2x external, non-detachable antennas - USB 2.0 Port - UART (J1) header on PCB (115200 8n1) - 8x LED, 2x button, power input switch Flash instruction: The only way to flash LEDE image in mr3420v5 is to use tftp recovery mode in U-Boot: 1. Configure PC with static IP 192.168.0.225/24 and tftp server. 2. Rename "lede-ramips-mt7628-tplink_tl-mr3420-v5-squashfs-tftp-recovery.bin" to "tp_recovery.bin" and place it in tftp server directory. 3. Connect PC with one of LAN ports, press the reset button, power up the router and keep button pressed for around 6-7 seconds, until device starts downloading the file. 4. Router will download file from server, write it to flash and reboot. Signed-off-by: Henryk Heisig <hyniu@o2.pl>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt76x8.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index e11a89bb55..8bbbcf6ad9 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -139,6 +139,20 @@ define Device/tl-wr841n-v13
endef
TARGET_DEVICES += tl-wr841n-v13
+define Device/tplink_tl-mr3420-v5
+ $(Device/tplink)
+ DTS := TL-MR3420V5
+ IMAGE_SIZE := 7808k
+ DEVICE_TITLE := TP-Link TL-MR3420 v5
+ TPLINK_FLASHLAYOUT := 8Mmtk
+ TPLINK_HWID := 0x34200005
+ TPLINK_HWREV := 0x5
+ TPLINK_HWREVADD := 0x5
+ TPLINK_HVERSION := 3
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += tplink_tl-mr3420-v5
+
define Device/u7628-01-128M-16M
DTS := U7628-01-128M-16M
IMAGE_SIZE := 16064k