aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorGeorge Hopkins <george-hopkins@null.net>2017-10-28 14:24:21 +0200
committerJohn Crispin <john@phrozen.org>2018-02-13 11:18:07 +0100
commit13f9e40602707479aaffac0d68a952070f305b7d (patch)
tree3bbc790ad9f611e2febe89059b29c3704bf8796d /target/linux/ramips/image
parent520335506273ed248074f7b3d2ba8bec148dddaa (diff)
downloadupstream-13f9e40602707479aaffac0d68a952070f305b7d.tar.gz
upstream-13f9e40602707479aaffac0d68a952070f305b7d.tar.bz2
upstream-13f9e40602707479aaffac0d68a952070f305b7d.zip
ramips: add support for D-Link DAP-1522 A1
D-Link DAP-1522 is a wireless bridge/access point with 4 LAN ports and a dual-band wireless chipset. Specifications: - Ralink RT2880 - 32 MB of RAM - 4 MB of Flash - 4x 10/100/1000 Mbps Ethernet (RTL8366SR) - 802.11abgn (RT2850) Flash Instructions: 1. Download lede-ramips-rt288x-dap-1522-a1-squashfs-factory.bin 2. Open the web interface and upload the image Signed-off-by: George Hopkins <george-hopkins@null.net>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/rt288x.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ramips/image/rt288x.mk b/target/linux/ramips/image/rt288x.mk
index 86a506388c..e9627a7431 100644
--- a/target/linux/ramips/image/rt288x.mk
+++ b/target/linux/ramips/image/rt288x.mk
@@ -30,6 +30,22 @@ define Device/ar725w
endef
TARGET_DEVICES += ar725w
+define Device/dap-1522-a1
+ DTS := DAP-1522-A1
+ BLOCKSIZE := 64k
+ IMAGE_SIZE := 3801088
+ DEVICE_TITLE := D-Link DAP-1522 A1
+ DEVICE_PACKAGES := kmod-switch-rtl8366s
+ KERNEL := $(KERNEL_DTB)
+ IMAGES += factory.bin
+ IMAGE/factory.bin := \
+ append-kernel | pad-offset $$$$(BLOCKSIZE) 96 | \
+ append-rootfs | pad-rootfs -x 96 | \
+ wrg-header wapnd01_dlink_dap1522 | \
+ check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += dap-1522-a1
+
define Device/f5d8235-v1
IMAGE_SIZE := 7744k
DEVICE_TITLE := Belkin F5D8235 V1