aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-08-30 10:51:09 +0200
committerJo-Philipp Wich <jo@mein.io>2018-08-30 10:58:38 +0200
commit0f3ec67a838856a4114406a6de5789fdb36600bd (patch)
treeecbe11c537177a95b6bb1a38049a0bf2ba43bedd /target/linux/ramips/image
parentcd49f57ff7f66588c9ad0b5ec66b9ef668a5d69d (diff)
downloadupstream-0f3ec67a838856a4114406a6de5789fdb36600bd.tar.gz
upstream-0f3ec67a838856a4114406a6de5789fdb36600bd.tar.bz2
upstream-0f3ec67a838856a4114406a6de5789fdb36600bd.zip
ramips: only limit lzma dictionary size on mt7621
The changed dictionary size leads to a different LZMA header which breaks sysupgrade image magic checkibng on at least some RT288x boards. Since the commit message only mentions testing on MT7621 and since the change appears to break at least one other ramips subtarget, do not take any chances and restrict the size limitation to only MT7621. Fixes FS#1797 Fixes 09b6755946 ("ramips: limit dictionary size for lzma compression") Signed-off-by: Jo-Philipp Wich <jo@mein.io> (cherry picked from commit 77e2bccde8f7f98603f60473023dadec4f473cf6)
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile2
-rw-r--r--target/linux/ramips/image/mt7621.mk1
2 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index cd77ffe411..8ab8aa3a6c 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -31,7 +31,7 @@ loadaddr-$(CONFIG_TARGET_ramips_mt7621) := 0x80001000
KERNEL_LOADADDR := $(loadaddr-y)
-KERNEL_DTB = kernel-bin | patch-dtb | lzma -d21
+KERNEL_DTB = kernel-bin | patch-dtb | lzma
define Device/Default
PROFILES = Default $$(DTS)
KERNEL_DEPENDS = $$(wildcard ../dts/$$(DTS).dts)
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index e9e2d3ecef..c8de8bd5ff 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -2,6 +2,7 @@
# MT7621 Profiles
#
+KERNEL_DTB += -d21
DEVICE_VARS += TPLINK_BOARD_ID TPLINK_HEADER_VERSION TPLINK_HWID TPLINK_HWREV
define Build/elecom-wrc-factory