aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorGeorgi Vlaev <georgi.vlaev@gmail.com>2019-04-17 21:17:45 +0300
committerDavid Bauer <mail@david-bauer.net>2019-07-17 23:14:23 +0200
commit8c51ddeff0876b439ac35a3f492ab719085bfb9c (patch)
tree1b442df904a7c4c884a54d9ded0d1dc936cf2013 /target/linux/ramips/image
parentd6198d8625310cd1ad22113f137e48261fcc8ff6 (diff)
downloadupstream-8c51ddeff0876b439ac35a3f492ab719085bfb9c.tar.gz
upstream-8c51ddeff0876b439ac35a3f492ab719085bfb9c.tar.bz2
upstream-8c51ddeff0876b439ac35a3f492ab719085bfb9c.zip
ramips: add support for TP-Link RE650 v1
TP-Link RE650 v1 is a dual-band AC2600 range extender, based on MediaTek MT7621A and MT7615E. According to the wikidevi entry for RE650 this device is identical with TP-Link RE500 as hardware. This patch supports only RE650. Hardware specification: - SoC 880 MHz - MediaTek MT7621AT - 128 MB of DDR3 RAM - 16 MB - Winbond 25Q128FVSG - 4T4R 2.4 GHz - MediaTek MT7615E - 4T4R 5 GHz - MediaTek MT7615E - 1x 1 Gbps Ethernet - MT7621AT integrated - 7x LEDs (Power, 2G, 5G, WPS(x2), Lan(x2)) - 4x buttons (Reset, Power, WPS, LED) - UART header (J1) - 2:GND, 3:RX, 4:TX Serial console @ 57600,8n1 Flash instructions: Upload openwrt-ramips-mt7621-tplink_re650-v1-squashfs-factory.bin from the RE650 web interface. TFTP recovery to stock firmware: Unfortunately, I can't find an easy way to recover the RE without opening the device and using modified binaries. The TFTP upload will only work if selected from u-boot, which means you have to open the device and attach to the serial console. The TFTP update procedure does *not* accept the published vendor firmware binaries. However, it allows to flash kernel + rootfs binaries, and this works if you have a backup of the original contents of the flash. It's probably possible to create special image out of the vendor binaries and use that as recovery image. Signed-off-by: Georgi Vlaev <georgi.vlaev@gmail.com> [re-added variables for kernel header] Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk30
1 files changed, 23 insertions, 7 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index a48aedd661..73ded64e74 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -531,25 +531,41 @@ define Device/totolink_a7000r
endef
TARGET_DEVICES += totolink_a7000r
-define Device/tplink_re350-v1
+define Device/tplink-safeloader
MTK_SOC := mt7621
DEVICE_VENDOR := TP-Link
- DEVICE_MODEL := RE350
- DEVICE_VARIANT := v1
- DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 wpad-basic
- TPLINK_BOARD_ID := RE350-V1
+ TPLINK_BOARD_ID :=
TPLINK_HWID := 0x0
TPLINK_HWREV := 0
TPLINK_HEADER_VERSION := 1
- IMAGE_SIZE := 6016k
KERNEL := $(KERNEL_DTB) | tplink-v1-header -e -O
IMAGES += factory.bin
- IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade | append-metadata | check-size $$$$(IMAGE_SIZE)
+ IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade | \
+ append-metadata | check-size $$$$(IMAGE_SIZE)
IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
+endef
+
+define Device/tplink_re350-v1
+ $(Device/tplink-safeloader)
+ DEVICE_MODEL := RE350
+ DEVICE_VARIANT := v1
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 wpad-basic
+ TPLINK_BOARD_ID := RE350-V1
+ IMAGE_SIZE := 6016k
SUPPORTED_DEVICES += re350-v1
endef
TARGET_DEVICES += tplink_re350-v1
+define Device/tplink_re650-v1
+ $(Device/tplink-safeloader)
+ DEVICE_MODEL := RE650
+ DEVICE_VARIANT := v1
+ DEVICE_PACKAGES := kmod-mt7615e wpad-basic
+ TPLINK_BOARD_ID := RE650-V1
+ IMAGE_SIZE := 14208k
+endef
+TARGET_DEVICES += tplink_re650-v1
+
define Device/ubiquiti_edgerouterx
MTK_SOC := mt7621
FILESYSTEMS := squashfs