aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-12-11 15:04:13 +0000
committerJohn Crispin <john@openwrt.org>2015-12-11 15:04:13 +0000
commit9f14006809f6122d68e22394d147e6fe4a47e676 (patch)
treee15a22746785c0ce49e971f412981c5491efce7e /target/linux/ramips/image
parent6cbb1be464941591c567d707a423d4aaea496f1d (diff)
downloadupstream-9f14006809f6122d68e22394d147e6fe4a47e676.tar.gz
upstream-9f14006809f6122d68e22394d147e6fe4a47e676.tar.bz2
upstream-9f14006809f6122d68e22394d147e6fe4a47e676.zip
ramips: add additional support for MQmaker WiTi board
The board is based on mt7621AT cpu, and has 16mb nor flash, 256mb of ram, 2 sata ports, microsd card slot, 1 USB 3.0 port and at least one 2.4 and one 5 ghz antenna. This is the 6th submission that adds support for XHCI in the device tree file, along with switching the location of the 2 radio's and addition of the kmod-i2c-mt7621 in the default packages of the profile. Signed-off-by: Sebastian Careba <nitroshift@yahoo.com> SVN-Revision: 47845
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 01e3fcbf11..63d6222223 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -954,7 +954,7 @@ endif
#
ifeq ($(SUBTARGET),mt7621)
- TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1 firewrt pbr-m1 re6500 sap-g3200u3 zbt-wg2626 wf-2881
+ TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1 firewrt pbr-m1 re6500 sap-g3200u3 witi wf-2881 zbt-wg2626
endif
define Device/mt7621
@@ -1004,6 +1004,11 @@ define Device/sap-g3200u3
DTS := SAP-G3200U3
endef
+define Device/witi
+ DTS := WITI
+ IMAGE_SIZE := $(ralink_default_fw_size_16M)
+endef
+
define Device/zbt-wg2626
DTS := ZBT-WG2626
IMAGE_SIZE := $(ralink_default_fw_size_16M)