aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-09-01 13:21:49 +0000
committerJohn Crispin <blogic@openwrt.org>2014-09-01 13:21:49 +0000
commit9956d339e9803f3808473453071464acd5aa0fb1 (patch)
tree4eb4bcc85d38052f6ef359033c93afbc90c4211b /target/linux/ramips/image
parent8ef1c93002fd8a04903e6bba1a2dea018bd6af28 (diff)
downloadupstream-9956d339e9803f3808473453071464acd5aa0fb1.tar.gz
upstream-9956d339e9803f3808473453071464acd5aa0fb1.tar.bz2
upstream-9956d339e9803f3808473453071464acd5aa0fb1.zip
ramips: Add support for VoCore
This is based and tested on VoCore Alpha, but other stuff like status/eth LEDs are present on the final board revision + VoDock. All GPIOs are exported, except spi/i2c. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> Backport of r41939 git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@42376 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 053dbdd5e4..2de3328ab4 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -476,6 +476,8 @@ Image/Build/Profile/SL-R7205=$(call BuildFirmware/Default4M/$(1),$(1),sl-r7205,S
Image/Build/Profile/V22RW-2X2=$(call BuildFirmware/Default4M/$(1),$(1),v22rw-2x2,V22RW-2X2)
+Image/Build/Profile/VOCORE=$(call BuildFirmware/Default8M/$(1),$(1),vocore,VOCORE)
+
Image/Build/Profile/W150M=$(call BuildFirmware/CustomFlashFactory/$(1),$(1),w150m,W150M,$(ralink_default_fw_size_4M),W150M Kernel Image,factory)
Image/Build/Profile/W306R_V20=$(call BuildFirmware/CustomFlashFactory/$(1),$(1),w306r-v20,W306R_V20,$(ralink_default_fw_size_4M),linkn Kernel Image,factory)
@@ -617,6 +619,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/SL-R7205,$(1))
$(call Image/Build/Profile/UR-326N4G,$(1))
$(call Image/Build/Profile/V22RW-2X2,$(1))
+ $(call Image/Build/Profile/VOCORE,$(1))
$(call Image/Build/Profile/W150M,$(1))
$(call Image/Build/Profile/W306R_V20,$(1))
$(call Image/Build/Profile/W502U,$(1))