aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-02-19 16:44:49 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-02-19 16:44:49 +0000
commit75603b2e322374f57b05a60f3f0803be43800800 (patch)
treea8268ed5303c51478f75580749e820f26f477234 /target/linux/ramips/image
parent2f78e4449f9b7496ae26d95e31afe0030e8eda01 (diff)
downloadupstream-75603b2e322374f57b05a60f3f0803be43800800.tar.gz
upstream-75603b2e322374f57b05a60f3f0803be43800800.tar.bz2
upstream-75603b2e322374f57b05a60f3f0803be43800800.zip
ramips: rt305x: add support for the Skyline SL-R7205 Wireless 3G router
[juhosg: - don't switch back to 2.6.39 - update config-3.2 - change machine id to SL-R7205 - reorder case entries in platform scripts - remove button hotplug script] Signed-off-by: Haipoh Teoh <hpteoh@ceedtec.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30645 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 347bafdb76..588dfa55fb 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -313,6 +313,10 @@ define Image/Build/Profile/WR5123GN
$(call Image/Build/Template/GENERIC_8M,$(1),wr512-3gn-8M,WR512-3GN)
endef
+define Image/Build/Profile/SLR7205
+ $(call Image/Build/Template/GENERIC_4M,$(1),sl-r7205,SL-R7205)
+endef
+
ifeq ($(CONFIG_RALINK_RT305X),y)
define Image/Build/Profile/Default
$(call Image/Build/Profile/ARGUS_ATP52B,$(1))
@@ -327,6 +331,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/NW718,$(1))
$(call Image/Build/Profile/OMNIEMB,$(1))
$(call Image/Build/Profile/PWH2004,$(1))
+ $(call Image/Build/Profile/SLR7205,$(1))
$(call Image/Build/Profile/WHRG300N,$(1))
$(call Image/Build/Profile/WCR150GN,$(1))
$(call Image/Build/Profile/F5D8235V2,$(1))