aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/rt3883.mk
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-11-20 21:28:38 +0100
committerMathias Kresin <dev@kresin.me>2016-11-23 08:36:11 +0100
commit8f561c651656add4cfad6e50a621050f0393007b (patch)
tree87d56686aed06c8a7834fbda8787ce7822aca7de /target/linux/ramips/image/rt3883.mk
parentf1d0eba3eaf1e65ed4a185bb620540f6adbcc945 (diff)
downloadupstream-8f561c651656add4cfad6e50a621050f0393007b.tar.gz
upstream-8f561c651656add4cfad6e50a621050f0393007b.tar.bz2
upstream-8f561c651656add4cfad6e50a621050f0393007b.zip
ramips: do not append metadata to CY-SWR1100 factory image
Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image/rt3883.mk')
-rw-r--r--target/linux/ramips/image/rt3883.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/rt3883.mk b/target/linux/ramips/image/rt3883.mk
index 3eac274263..5fe4a71328 100644
--- a/target/linux/ramips/image/rt3883.mk
+++ b/target/linux/ramips/image/rt3883.mk
@@ -26,7 +26,7 @@ define Device/cy-swr1100
append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | \
append-rootfs | pad-rootfs -x 64 | \
seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \
- seama-seal -m "signature=wrgnd10_samsung_ss815" | append-metadata | \
+ seama-seal -m "signature=wrgnd10_samsung_ss815" | \
check-size $$$$(IMAGE_SIZE)
DEVICE_TITLE := Samsung CY-SWR1100
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
84' href='#n184'>184 185 186 187 188
<?xml version="1.0" encoding="utf-8"?>
<!--
/*
 * ConnectBot: simple, powerful, open-source SSH client for Android
 * Copyright 2007 Kenny Root, Jeffrey Sharkey
 *
 * Licensed under the Apache License, Version 2.0 (the "License");
 * you may not use this file except in compliance with the License.
 * You may obtain a copy of the License at
 *
 *     http://www.apache.org/licenses/LICENSE-2.0
 *
 * Unless required by applicable law or agreed to in writing, software
 * distributed under the License is distributed on an "AS IS" BASIS,
 * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
 * See the License for the specific language governing permissions and
 * limitations under the License.
 */
-->

<PreferenceScreen xmlns:android="http://schemas.android.com/apk/res/android">

	<org.connectbot.util.SwitchCompatPreference
		android:key="memkeys"
		android:title="@string/pref_memkeys_title"
		android:summary="@string/pref_memkeys_summary"
		android:defaultValue="true"
		/>

	<org.connectbot.util.SwitchCompatPreference
		android:key="connPersist"
		android:title="@string/pref_conn_persist_title"
		android:summary="@string/pref_conn_persist_summary"
		android:defaultValue="true"
		/>

	<org.connectbot.util.SwitchCompatPreference
		android:key="wifilock"
		android:title="@string/pref_wifilock_title"
		android:summary="@string/pref_wifilock_summary"
		android:defaultValue="true"
		/>

	<PreferenceCategory
		android:title="@string/pref_emulation_category">

		<ListPreference
			android:key="emulation"
			android:title="@string/pref_emulation_title"
			android:summary="@string/pref_emulation_summary"
			android:entries="@array/list_emulation_modes"
			android:entryValues="@array/list_emulation_modes"
			android:defaultValue="screen"
			/>

		<EditTextPreference
			android:key="scrollback"
			android:title="@string/pref_scrollback_title"
			android:summary="@string/pref_scrollback_summary"
			android:defaultValue="140"
			android:numeric="integer"
			/>

	</PreferenceCategory>

	<PreferenceCategory
		android:title="@string/pref_ui_category">

		<ListPreference
			android:key="rotation"
			android:title="@string/pref_rotation_title"
			android:summary="@string/pref_rotation_summary"
			android:entries="@array/list_rotation"
			android:entryValues="@array/list_rotation_values"
			android:defaultValue="Default"
			/>

		<org.connectbot.util.SwitchCompatPreference
			android:key="titlebarhide"
			android:title="@string/pref_titlebarhide_title"
			android:summary="@string/pref_titlebarhide_summary"
			android:defaultValue="false"
			/>

		<org.connectbot.util.SwitchCompatPreference
			android:key="fullscreen"
			android:title="@string/pref_fullscreen_title"
			android:summary="@string/pref_fullscreen_summary"
			android:defaultValue="false"
			/>

		<org.connectbot.util.SwitchCompatPreference
			android:key="volumefont"
			android:title="@string/pref_volumefont_title"
			android:summary="@string/pref_volumefont_summary"
			android:defaultValue="true"
			/>

		<org.connectbot.util.SwitchCompatPreference
			android:key="keepalive"
			android:title="@string/pref_keepalive_title"
			android:summary="@string/pref_keepalive_summary"
			android:defaultValue="true"
			/>
	</PreferenceCategory>

	<PreferenceCategory
		android:title="@string/pref_keyboard_category">

		<org.connectbot.util.SwitchCompatPreference
			android:key="shiftfkeys"
			android:title="@string/pref_shiftfkeys_title"
			android:summary="@string/pref_shiftfkeys_summary"
			android:defaultValue="false"
			/>

		<org.connectbot.util.SwitchCompatPreference
			android:key="ctrlfkeys"
			android:title="@string/pref_ctrlfkeys_title"
			android:summary="@string/pref_ctrlfkeys_summary"
			android:defaultValue="false"
			/>

		<ListPreference
			android:key="stickymodifiers"
			android:title="@string/pref_stickymodifiers_title"
			android:summary="@string/pref_stickymodifiers_summary"
			android:entries="@array/list_stickymodifiers"
			android:entryValues="@array/list_stickymodifiers_values"
			android:defaultValue="no"
			/>

		<ListPreference
			android:key="keymode"
			android:title="@string/pref_keymode_title"
			android:summary="@string/pref_keymode_summary"
			android:entries="@array/list_keymode"
			android:entryValues="@array/list_keymode_values"
			android:defaultValue="none"
			/>

		<ListPreference
			android:key="camera"
			android:title="@string/pref_camera_title"
			android:summary="@string/pref_camera_summary"
			android:entries="@array/list_camera"
			android:entryValues="@array/list_camera_values"
			android:defaultValue="Ctrl+A then Space"
			/>

		<org.connectbot.util.SwitchCompatPreference
			android:key="bumpyarrows"
			android:title="@string/pref_bumpyarrows_title"
			android:summary="@string/pref_bumpyarrows_summary"
			android:defaultValue="true"
			/>
	</PreferenceCategory>

	<PreferenceCategory
		android:title="@string/pref_bell_category">

		<org.connectbot.util.SwitchCompatPreference
			android:key="bell"
			android:title="@string/pref_bell_title"
			android:defaultValue="true"
			/>

		<org.connectbot.util.VolumePreference
			android:key="bellVolume"
			android:title="@string/pref_bell_volume_title"
			/>

		<org.connectbot.util.SwitchCompatPreference
			android:key="bellVibrate"
			android:title="@string/pref_bell_vibrate_title"
			android:defaultValue="true"
			/>

		<org.connectbot.util.SwitchCompatPreference
			android:key="bellNotification"
			android:title="@string/pref_bell_notification_title"
			android:summary="@string/pref_bell_notification_summary"
			android:defaultValue="false"
			/>

	</PreferenceCategory>

</PreferenceScreen>