aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/rt3883.mk
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-12-29 19:25:00 +0100
committerMathias Kresin <dev@kresin.me>2018-12-30 20:08:12 +0100
commit7c1332d95fbaea2e0a5029947a2b8d3d43c171b4 (patch)
treee8c69566ba38214068e6906ceec07c33c7657298 /target/linux/ramips/image/rt3883.mk
parentd3bf5ff9bc7b55b2a3dab93853b33a0cd2c4ca47 (diff)
downloadupstream-7c1332d95fbaea2e0a5029947a2b8d3d43c171b4.tar.gz
upstream-7c1332d95fbaea2e0a5029947a2b8d3d43c171b4.tar.bz2
upstream-7c1332d95fbaea2e0a5029947a2b8d3d43c171b4.zip
ramips: consolidate seama image build code
Create a common template which has the required image build code defined. Add some new variables to pass individual parts to the seama recipes. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image/rt3883.mk')
-rw-r--r--target/linux/ramips/image/rt3883.mk26
1 files changed, 4 insertions, 22 deletions
diff --git a/target/linux/ramips/image/rt3883.mk b/target/linux/ramips/image/rt3883.mk
index f90fc6154f..abee533d01 100644
--- a/target/linux/ramips/image/rt3883.mk
+++ b/target/linux/ramips/image/rt3883.mk
@@ -18,20 +18,11 @@ endef
TARGET_DEVICES += br-6475nd
define Device/cy-swr1100
+ $(Device/seama)
DTS := CY-SWR1100
BLOCKSIZE := 64k
KERNEL := $(KERNEL_DTB)
- IMAGES += factory.bin
- IMAGE/sysupgrade.bin := \
- append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-rootfs | \
- seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \
- pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
- IMAGE/factory.bin := \
- append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | \
- append-rootfs | pad-rootfs -x 64 | \
- seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \
- seama-seal -m "signature=wrgnd10_samsung_ss815" | \
- check-size $$$$(IMAGE_SIZE)
+ SEAMA_SIGNATURE := wrgnd10_samsung_ss815
DEVICE_TITLE := Samsung CY-SWR1100
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
endef
@@ -39,20 +30,11 @@ TARGET_DEVICES += cy-swr1100
define Device/dir-645
+ $(Device/seama)
DTS := DIR-645
BLOCKSIZE := 4k
KERNEL := $(KERNEL_DTB)
- IMAGES += factory.bin
- IMAGE/sysupgrade.bin := \
- append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-rootfs | \
- seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \
- pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
- IMAGE/factory.bin := \
- append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | \
- append-rootfs | pad-rootfs -x 64 | \
- seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \
- seama-seal -m "signature=wrgn39_dlob.hans_dir645" | \
- check-size $$$$(IMAGE_SIZE)
+ SEAMA_SIGNATURE := wrgn39_dlob.hans_dir645
DEVICE_TITLE := D-Link DIR-645
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
endef