aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/rt3883.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-07-15 14:55:37 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-07-25 14:31:27 +0200
commit363197311b342a59b3c67e4bd2dfea3b3030b456 (patch)
tree011d1f66850ea187a3e74f3badec2d108e705234 /target/linux/ramips/image/rt3883.mk
parent24ded1810b071ec7e7c8d134e5491d9649c13dac (diff)
downloadupstream-363197311b342a59b3c67e4bd2dfea3b3030b456.tar.gz
upstream-363197311b342a59b3c67e4bd2dfea3b3030b456.tar.bz2
upstream-363197311b342a59b3c67e4bd2dfea3b3030b456.zip
ramips: remove default IMAGE_SIZE for ramips target
Currently, ramips target defines 0x7b0000 as default IMAGE_SIZE for all devices in ramips target, i.e. this will be set if a device does not specify IMAGE_SIZE itself. From 92 devices using that default due to a "missing" IMAGE_SIZE, 14 were incorrect by a small amount (i.e. still "8M" flash) and 12 were completely off ("16M", "4M", ...). This patch thus removes the _default_ IMAGE_SIZE and defines IMAGE_SIZE for each device individually. This should indicate to people supporting new devices that this parameter has to be cared about. For the present code, this patch is cosmetical. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/rt3883.mk')
-rw-r--r--target/linux/ramips/image/rt3883.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/ramips/image/rt3883.mk b/target/linux/ramips/image/rt3883.mk
index b04cb8f071..ae9c10aca1 100644
--- a/target/linux/ramips/image/rt3883.mk
+++ b/target/linux/ramips/image/rt3883.mk
@@ -8,6 +8,7 @@ endef
define Device/asus_rt-n56u
MTK_SOC := rt3883
BLOCKSIZE := 64k
+ IMAGE_SIZE := $(ralink_default_fw_size_8M)
IMAGE/sysupgrade.bin += | mkrtn56uimg -s
DEVICE_VENDOR := Asus
DEVICE_MODEL := RT-N56U
@@ -34,6 +35,7 @@ define Device/dlink_dir-645
$(Device/seama)
MTK_SOC := rt3883
BLOCKSIZE := 4k
+ IMAGE_SIZE := $(ralink_default_fw_size_8M)
KERNEL := $(KERNEL_DTB)
SEAMA_SIGNATURE := wrgn39_dlob.hans_dir645
DEVICE_VENDOR := D-Link
@@ -60,6 +62,7 @@ TARGET_DEVICES += edimax_br-6475nd
define Device/loewe_wmdr-143n
MTK_SOC := rt3883
BLOCKSIZE := 64k
+ IMAGE_SIZE := $(ralink_default_fw_size_8M)
DEVICE_VENDOR := Loewe
DEVICE_MODEL := WMDR-143N
SUPPORTED_DEVICES += wmdr-143n
@@ -81,6 +84,7 @@ define Device/samsung_cy-swr1100
$(Device/seama)
MTK_SOC := rt3883
BLOCKSIZE := 64k
+ IMAGE_SIZE := $(ralink_default_fw_size_8M)
KERNEL := $(KERNEL_DTB)
SEAMA_SIGNATURE := wrgnd10_samsung_ss815
DEVICE_VENDOR := Samsung
@@ -107,6 +111,7 @@ TARGET_DEVICES += sitecom_wlr-6000
define Device/trendnet_tew-691gr
MTK_SOC := rt3883
BLOCKSIZE := 64k
+ IMAGE_SIZE := $(ralink_default_fw_size_8M)
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
umedia-header 0x026910
@@ -120,6 +125,7 @@ TARGET_DEVICES += trendnet_tew-691gr
define Device/trendnet_tew-692gr
MTK_SOC := rt3883
BLOCKSIZE := 64k
+ IMAGE_SIZE := $(ralink_default_fw_size_8M)
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
umedia-header 0x026920